Browse Source

starting ocata development patch

Change-Id: I6e98a1403732852e8dbf3ccfa436723ef696eeb5
Jan Klare 2 years ago
parent
commit
e3e7d54dad
2 changed files with 13 additions and 6 deletions
  1. 11
    4
      .rubocop_todo.yml
  2. 2
    2
      metadata.rb

+ 11
- 4
.rubocop_todo.yml View File

@@ -1,11 +1,18 @@
1
-# This configuration was generated by `rubocop --auto-gen-config`
2
-# on 2015-05-29 12:01:24 -0500 using RuboCop version 0.29.1.
1
+# This configuration was generated by
2
+# `rubocop --auto-gen-config`
3
+# on 2017-02-23 16:58:35 +0100 using RuboCop version 0.39.0.
3 4
 # The point is for the user to remove these configuration records
4 5
 # one by one as the offenses are removed from the code base.
5 6
 # Note that changes in the inspected code, or installation of new
6 7
 # versions of RuboCop, may require this file to be generated again.
7 8
 
8
-# Offense count: 4
9
+# Offense count: 5
9 10
 # Configuration parameters: EnforcedStyle, SupportedStyles.
11
+# SupportedStyles: nested, compact
10 12
 Style/ClassAndModuleChildren:
11
-  Enabled: false
13
+  Exclude:
14
+    - 'recipes/mariadb-server.rb'
15
+    - 'recipes/mysql-server.rb'
16
+    - 'recipes/openstack-db.rb'
17
+    - 'recipes/percona-cluster-server.rb'
18
+    - 'recipes/postgresql-server.rb'

+ 2
- 2
metadata.rb View File

@@ -5,7 +5,7 @@ issues_url 'https://launchpad.net/openstack-chef' if respond_to?(:issues_url)
5 5
 source_url 'https://github.com/openstack/cookbook-openstack-ops-database' if respond_to?(:source_url)
6 6
 license 'Apache 2.0'
7 7
 description 'Provides the shared database configuration for Chef for OpenStack.'
8
-version '14.0.0'
8
+version '15.0.0'
9 9
 
10 10
 recipe 'client', 'Installs client packages for the database used by the deployment.'
11 11
 recipe 'server', 'Installs and configures server packages for the database used by the deployment.'
@@ -27,4 +27,4 @@ depends 'mysql', '~> 8.2'
27 27
 depends 'mysql2_chef_gem', '~> 1.1'
28 28
 depends 'postgresql', '~> 5.1'
29 29
 depends 'database', '~> 6.1'
30
-depends 'openstack-common', '>= 14.0.0'
30
+depends 'openstack-common', '>= 15.0.0'

Loading…
Cancel
Save