Browse Source

Update lower-constraints versions

This updates lower constraints to versions that will work with py38 so
that when we move to running on focal nodes, which has py38 as its
default py3 runtime, the lower-constraints job will continue to pass.

It also cleans out some secondary requirements that are no longer needed
due to our direct dependencies being updated.

Linters are removed that are kept in the global requirements blacklist
as those are not version tracked and are not relevant for our
lower-constraints unit test runs.

Change-Id: I78945d43111fe7a2a38c17432b9dcd66a6116186
Signed-off-by: Sean McGinnis <sean.mcginnis@gmail.com>
tags/2.2.0^0
Sean McGinnis 1 month ago
parent
commit
649189dbc4
No known key found for this signature in database GPG Key ID: CE7EE4BFAF8D70C8
2 changed files with 19 additions and 9 deletions
  1. +18
    -8
      lower-constraints.txt
  2. +1
    -1
      test-requirements.txt

+ 18
- 8
lower-constraints.txt View File

@@ -1,24 +1,27 @@
alabaster==0.7.10
Babel==2.3.4
chardet==3.0.4
cliff==3.2.0
cmd2==0.8.9
coverage==4.0
doc8==0.6.0
doc8==0.8.1
docutils==0.11
dulwich==0.15.0
entrypoints==0.3
extras==1.0.0
fixtures==3.0.0
flake8==2.2.4
hacking==0.10.3
future==0.18.2
imagesize==0.7.1
Jinja2==2.10
linecache2==1.0.0
MarkupSafe==1.0
mccabe==0.2.1
openstackdocstheme==2.2.1
packaging==20.4
pbr==2.0.0
pep8==1.5.7
pyflakes==0.8.1
prettytable==0.7.2
Pygments==2.2.0
pyparsing==2.4.7
pyperclip==1.8.0
python-mimeparse==1.6.0
python-subunit==1.0.0
pytz==2013.6
@@ -29,10 +32,17 @@ restructuredtext-lint==1.1.1
six==1.10.0
snowballstemmer==1.2.1
Sphinx==2.0.0
sphinxcontrib-websupport==1.0.1
stevedore==1.20.0
sphinxcontrib-applehelp==1.0.2
sphinxcontrib-devhelp==1.0.2
sphinxcontrib-htmlhelp==1.0.3
sphinxcontrib-jsmath==1.0.1
sphinxcontrib-qthelp==1.0.3
sphinxcontrib-serializinghtml==1.1.4
stestr==2.0.0
stevedore==1.20.0
testtools==2.2.0
traceback2==1.4.0
unittest2==1.1.0
voluptuous==0.11.7
wcwidth==0.2.4
wrapt==1.7.0

+ 1
- 1
test-requirements.txt View File

@@ -11,5 +11,5 @@ openstackdocstheme>=2.2.1 # Apache-2.0
stestr>=2.0.0 # Apache-2.0
testtools>=2.2.0 # MIT
fixtures>=3.0.0 # Apache-2.0/BSD
doc8>=0.6.0 # Apache-2.0
doc8>=0.8.1 # Apache-2.0
reno>=3.1.0 # Apache-2.0

Loading…
Cancel
Save