Browse Source

[goal] Migrate testing to ubuntu focal

As per victoria cycle testing runtime and community goal[1]
we need to migrate upstream CI/CD to Ubuntu Focal(20.04).

Fixing:
Closes-Bug: #1886298
Bump the lower constraints for required deps which added python3.8
support in their later version.

This patch update python version to py38 in package.json and
karma.conf.js as py36 is not available on focal. It also adds
libfontconfig1 in bindep.txt as phantomjs requires libfontconfig[2].

Story: #2007865
Task: #40182

Depends-On: https://review.opendev.org/#/c/744647/

[1] https://governance.openstack.org/tc/goals/selected/victoria/migrate-ci-cd-jobs-to-ubuntu-focal
[2] https://www.npmjs.com/package/phantomjs-prebuilt#linux-note

Change-Id: I6d2689cfbe019a5c6ee22ff3f3666981502f2ce4
changes/14/744714/15 11.0.0
manchandavishal 11 months ago
committed by Vishal Manchanda
parent
commit
7b1adbd7be
4 changed files with 8 additions and 4 deletions
  1. +4
    -0
      bindep.txt
  2. +1
    -1
      karma.conf.js
  3. +1
    -1
      lower-constraints.txt
  4. +2
    -2
      package.json

+ 4
- 0
bindep.txt View File

@ -0,0 +1,4 @@
# This is a cross-platform list tracking distribution packages needed for install and tests;
# see https://docs.openstack.org/infra/bindep/ for additional information.
libfontconfig1 [nodejs platform:dpkg]

+ 1
- 1
karma.conf.js View File

@ -20,7 +20,7 @@ var path = require('path');
module.exports = function (config) {
// This tox venv is setup in the post-install npm step
var toxPath = '.tox/py36/lib/python3.6/site-packages/';
var toxPath = '.tox/py38/lib/python3.8/site-packages/';
var xstaticPath = toxPath + 'xstatic/pkg/';
config.set({


+ 1
- 1
lower-constraints.txt View File

@ -3,7 +3,7 @@ appdirs==1.4.3
asn1crypto==0.24.0
astroid==1.3.8
certifi==2018.1.18
cffi==1.11.5
cffi==1.14
chardet==3.0.4
cliff==2.11.0
cmd2==0.8.1


+ 2
- 2
package.json View File

@ -9,14 +9,14 @@
"eslint": "1.10.3",
"eslint-config-openstack": "1.2.4",
"jasmine-core": "2.4.1",
"karma": "1.1.2",
"karma": "~1.1.2",
"karma-chrome-launcher": "1.0.1",
"karma-cli": "1.0.1",
"karma-jasmine": "1.0.2",
"karma-ng-html2js-preprocessor": "1.0.0"
},
"scripts": {
"postinstall": "if [ ! -d .venv ]; then tox -epy36 --notest; fi",
"postinstall": "if [ ! -d .tox/py38 ]; then tox -epy38 --notest; fi",
"lint": "eslint --no-color designatedashboard/static",
"lintq": "eslint --quiet designatedashboard/static",
"test": "karma start karma.conf.js --single-run"


Loading…
Cancel
Save