Browse Source

Cleanup py27 support

This repo is now testing only with Python 3, so let's make
a few cleanups:
- Remove python 2.7 stanza from setup.py
- Add requires on python >= 3.6 to setup.cfg so that pypi and pip
  know about the requirement
- Remove obsolete sections from setup.cfg
- Update classifiers
- Update requirements, no need for python_version anymore
- Use newer openstackdocstheme and Sphinx versions
- Cleanup */source/conf.py to remove now obsolete content.
- Remove Babel from requirements, it's not needed for running.
- Update hacking to 3.0, fix problems found

Change-Id: I9eb22328474f52c2e225ae2a24c895c0e2bb63d7
changes/50/720750/4
Andreas Jaeger 1 year ago
parent
commit
7bace2a2cd
11 changed files with 14 additions and 31 deletions
  1. +1
    -0
      designatedashboard/dashboards/project/ngdns/reverse_dns/panel.py
  2. +1
    -0
      designatedashboard/dashboards/project/ngdns/zones/panel.py
  3. +2
    -2
      doc/requirements.txt
  4. +0
    -1
      doc/source/conf.py
  5. +2
    -3
      lower-constraints.txt
  6. +0
    -1
      releasenotes/source/conf.py
  7. +0
    -1
      requirements.txt
  8. +3
    -9
      setup.cfg
  9. +0
    -9
      setup.py
  10. +3
    -3
      test-requirements.txt
  11. +2
    -2
      tox.ini

+ 1
- 0
designatedashboard/dashboards/project/ngdns/reverse_dns/panel.py View File

@ -22,4 +22,5 @@ class ReverseDns(horizon.Panel):
slug = 'reverse_dns'
permissions = ('openstack.services.dns',)
dashboard.Project.register(ReverseDns)

+ 1
- 0
designatedashboard/dashboards/project/ngdns/zones/panel.py View File

@ -22,4 +22,5 @@ class Zones(horizon.Panel):
slug = 'dnszones'
permissions = ('openstack.services.dns',)
dashboard.Project.register(Zones)

+ 2
- 2
doc/requirements.txt View File

@ -1,2 +1,2 @@
openstackdocstheme>=1.30.0 # Apache-2.0
sphinxcontrib-svg2pdfconverter>=0.1.0 # BSD
openstackdocstheme>=2.0.0 # Apache-2.0
sphinxcontrib-svg2pdfconverter>=0.1.0 # BSD

+ 0
- 1
doc/source/conf.py View File

@ -31,7 +31,6 @@ extensions = [
repository_name = 'openstack/designate-dashboard'
bug_project = 'designate-dashboard'
bug_tag = ''
html_last_updated_fmt = '%Y-%m-%d %H:%M'
html_theme = 'openstackdocs'
# autodoc generation is a bit aggressive and a ndashboardsance when doing heavy


+ 2
- 3
lower-constraints.txt View File

@ -2,7 +2,6 @@ alabaster==0.7.10
appdirs==1.4.3
asn1crypto==0.24.0
astroid==1.3.8
Babel==2.3.4
certifi==2018.1.18
cffi==1.11.5
chardet==3.0.4
@ -49,7 +48,7 @@ msgpack==0.5.6
munch==2.2.0
netaddr==0.7.19
netifaces==0.10.6
openstackdocstheme==1.18.1
openstackdocstheme==2.0.0
openstacksdk==0.12.0
os-client-config==1.29.0
os-service-types==1.2.0
@ -99,7 +98,7 @@ semantic-version==2.6.0
simplejson==3.13.2
six==1.11.0
snowballstemmer==1.2.1
Sphinx==1.6.2
Sphinx==2.0.0
sphinxcontrib-websupport==1.0.1
stevedore==1.28.0
termcolor==1.1.0


+ 0
- 1
releasenotes/source/conf.py View File

@ -34,7 +34,6 @@ extensions = [
repository_name = 'openstack/designate-dashboard'
bug_project = 'designate-dashboard'
bug_tag = ''
html_last_updated_fmt = '%Y-%m-%d %H:%M'
html_theme = 'openstackdocs'
# Add any paths that contain templates here, relative to this directory.


+ 0
- 1
requirements.txt View File

@ -3,7 +3,6 @@
# process, which may cause wedges in the gate later.
oslo.log>=3.36.0 # Apache-2.0
pbr!=2.1.0,>=2.0.0 # Apache-2.0
Babel!=2.4.0,>=2.3.4 # BSD
python-designateclient>=2.7.0 # Apache-2.0
horizon>=17.1.0 # Apache-2.0

+ 3
- 9
setup.cfg View File

@ -6,6 +6,7 @@ description-file =
author = OpenStack
author-email = openstack-discuss@lists.openstack.org
home-page = https://docs.openstack.org/developer/designate-dashboard/
python-requires = >=3.6
classifier =
Environment :: OpenStack
Intended Audience :: Information Technology
@ -13,6 +14,8 @@ classifier =
License :: OSI Approved :: Apache Software License
Operating System :: POSIX :: Linux
Programming Language :: Python
Programming Language :: Python :: Implementation :: CPython
Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
@ -21,15 +24,6 @@ classifier =
packages =
designatedashboard
[build_sphinx]
source-dir = doc/source
build-dir = doc/build
all_files = 1
warning-is-error = 1
[upload_sphinx]
upload-dir = doc/build/html
[compile_catalog]
directory = designatedashboard/locale
domain = django


+ 0
- 9
setup.py View File

@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
# In python < 2.7.4, a lazy loading of package `pbr` will break
# setuptools if some other modules registered functions in `atexit`.
# solution from: http://bugs.python.org/issue15881#msg170215
try:
import multiprocessing # noqa
except ImportError:
pass
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)

+ 3
- 3
test-requirements.txt View File

@ -1,7 +1,7 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking>=1.1.0,<1.2.0 # Apache-2.0
hacking>=3.0,<3.1.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
mock>=2.0.0 # BSD
@ -10,6 +10,6 @@ pylint==1.4.5 # GPLv2
testrepository>=0.0.18 # Apache-2.0/BSD
testtools>=2.2.0 # MIT
unittest2>=1.1.0 # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2;python_version>='3.4' # BSD
openstackdocstheme>=1.18.1 # Apache-2.0
sphinx>=2.0.0,!=2.1.0 # BSD
openstackdocstheme>=2.0.0 # Apache-2.0
reno>=2.5.0 # Apache-2.0

+ 2
- 2
tox.ini View File

@ -54,9 +54,9 @@ commands =
# E123, E125 skipped as they are invalid PEP-8.
# F405 TEMPLATES may be undefined, or defined from star imports.
# (because it is not easy to avoid this in openstack_dashboard.test.settings)
# W504 line break after binary operator
show-source = True
ignore = E123,E125,F405
ignore = E123,E125,F405,W504
builtins = _
exclude=.venv,.git,.tox,dist,doc,*openstack/common*,*lib/python*,*egg,build,releasenotes,node_modules


Loading…
Cancel
Save