Browse Source

Pin stable/queens tempest tests to 0.7.0 tag

Master of designate-tempest-plugin has removed support for python
2.7, but the stable/queens designate runs on python2.7.
This patch will pin the tempest jobs to use the 0.7.0 tag for
designate-tempest-plugin as it was the last tag that supports
python2.7.
This patch also forces the grenade job to use python2.

Change-Id: I87d2a9de9178b0c8b41d4ac4c8b674b7900b3546
changes/47/725347/3
Michael Johnson 2 months ago
parent
commit
0dae66c1b4
2 changed files with 7 additions and 2 deletions
  1. +4
    -2
      .zuul.yaml
  2. +3
    -0
      devstack/upgrade/settings

+ 4
- 2
.zuul.yaml View File

@@ -11,7 +11,8 @@
- openstack/devstack-gate
- openstack/designate
- openstack/designate-dashboard
- openstack/designate-tempest-plugin
- name: openstack/designate-tempest-plugin
override-checkout: 0.7.0
- openstack/python-designateclient
- openstack/tempest
run: playbooks/legacy/designate-devstack-base/run.yaml
@@ -50,7 +51,8 @@
- openstack/devstack-gate
- openstack/designate
- openstack/designate-dashboard
- openstack/designate-tempest-plugin
- name: openstack/designate-tempest-plugin
override-checkout: 0.7.0
- openstack/python-designateclient
run: playbooks/legacy/grenade-devstack-designate-pdns4/run.yaml
post-run: playbooks/legacy/grenade-devstack-designate-pdns4/post.yaml


+ 3
- 0
devstack/upgrade/settings View File

@@ -7,5 +7,8 @@ devstack_localrc target enable_plugin designate https://git.openstack.org/openst
devstack_localrc base enable_service designate-api designate-central designate-producer designate-worker designate-mdns designate-agent designate-sink designate horizon
devstack_localrc target enable_service designate-api designate-central designate-producer designate-worker designate-mdns designate-agent designate-sink designate horizon

devstack_localrc base USE_PYTHON3=False
devstack_localrc target USE_PYTHON3=False

BASE_RUN_SMOKE=False
TARGET_RUN_SMOKE=False

Loading…
Cancel
Save