Browse Source

Bump ANSIBLE_VERSION default to 2.7.14

devstack-gate is still used for grenade jobs and restricts
ara<1.0.0 and defaults ANSIBLE_VERSION=2.5.7.

ARA 0.16.6 dropped support for ansible < 2.6 [1]. As such,
grenade jobs are failing because ara 0.16.6 cannot be installed.

This bumps the ANSIBLE_VERSION default to 2.7.14 which is current
as of Ubuntu Xenial 16.04 which should be sufficient for the
branches still supported in upstream OpenStack CI (mainly Ocata+).

[1] 872ba818fb

Story: 2007028
Task: 37825

Change-Id: If7874f6e74606fe8a79fbff48abf764cc41c4a3b
changes/63/699463/3
Matt Riedemann 1 year ago
committed by Clark Boylan
parent
commit
0443da119f
1 changed files with 3 additions and 1 deletions
  1. +3
    -1
      devstack-vm-gate-wrap.sh

+ 3
- 1
devstack-vm-gate-wrap.sh View File

@ -28,7 +28,9 @@ GIT_BRANCH=${GIT_BRANCH:-master}
# We're using enough ansible specific features that it's extremely
# possible that new ansible releases can break us. As such we should
# be very deliberate about which ansible we use.
ANSIBLE_VERSION=${ANSIBLE_VERSION:-2.5.7}
# NOTE(mriedem): Ansible 2.7.14 is current as of Ubuntu Xenial 16.04.
# ARA is pinned to <1.0.0 below which affects the required version of Ansible.
ANSIBLE_VERSION=${ANSIBLE_VERSION:-2.7.14}
export DSTOOLS_VERSION=${DSTOOLS_VERSION:-0.4.0}
# Set to 0 to skip stackviz


Loading…
Cancel
Save