Browse Source

Remove hacking from requirements

putting it in requirements means it's installed for anything that
installs diskimage-builder. Not just for tests, but in actual prod
installations. Because of the way flake8 plugins work, this means
then that hacking is injected into all flake8 invocations in that
environment.

This is currently causing issues in nodepool where we do not
actually use hacking but it's still spewing spurious messages to
the screen because it is incorrect finding our apache header to be
incorrect.

Just depend on flake8, since that's what dib-lint depends on.

Change-Id: I8d2b2076b604d596906a3b12a5518e2a56c0fe88
tags/2.34.1^0
Monty Taylor 3 months ago
parent
commit
1038f9c8ba
1 changed files with 1 additions and 1 deletions
  1. +1
    -1
      requirements.txt

+ 1
- 1
requirements.txt View File

@@ -10,4 +10,4 @@ PyYAML>=3.12 # MIT
six>=1.10.0 # MIT
stevedore>=1.20.0 # Apache-2.0
# NOTE(ianw) in here because dib-lint uses flake8
hacking>=1.1.0
flake8<4.0.0,>=3.6.0 # MIT

Loading…
Cancel
Save