Drop lower version requirement for networkx

With [1] to fix lower constraints job, networkx
requirement was bumped to 2.4.0, but since diskimage-builder
is branchless and to get it work with stable/train upper-constraints
for networkx i.e 2.3.0 can't bump to 2.4.0.
Also networkx-2.3.0 has dep on decorator>=4.3.0
so actual decorator issue with 3.4.0 shouldn't be there.

[1] https://review.opendev.org/c/openstack/diskimage-builder/+/811048
[2] https://github.com/networkx/networkx/blob/networkx-2.3/requirements/default.txt

Closes-Bug: #1945926
Change-Id: I93a2826019d9bb0d004f7daa661fdd1ca4269331
changes/53/812453/1
yatinkarel 1 year ago
parent 82aa8c516d
commit 8b4ad6dae6

@ -19,7 +19,7 @@ linecache2==1.0.0
MarkupSafe==1.0
mock==2.0.0
mox3==0.20.0
networkx==2.4.0
networkx==2.3.0
openstackdocstheme==1.18.1
os-client-config==1.28.0
oslotest==3.2.0

@ -2,7 +2,7 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
networkx>=2.4.0 # BSD
networkx>=2.3.0 # BSD
pbr!=2.1.0,>=2.0.0 # Apache-2.0
PyYAML>=3.12 # MIT
stevedore>=1.20.0 # Apache-2.0

Loading…
Cancel
Save