Browse Source

Install pbr before glean to address SNI issues

Some older distros (like centos8 and xenial) don't support SNI in their
easy_install implementations which are used to install setup_requires
for python packages. PBR is a setup_requires for glean. We work around
this problem when installing glean by preinstalling PBR with pip.

Change-Id: Ie9f5c9ed06954cbe51f23fe8cca0655a931a5201
changes/27/787827/1
Clark Boylan 3 weeks ago
parent
commit
da674c4e5b
2 changed files with 6 additions and 0 deletions
  1. +3
    -0
      diskimage_builder/elements/simple-init/install.d/simple-init-repo-install/40-glean
  2. +3
    -0
      diskimage_builder/elements/simple-init/install.d/simple-init-source-install/40-glean

+ 3
- 0
diskimage_builder/elements/simple-init/install.d/simple-init-repo-install/40-glean View File

@ -22,6 +22,9 @@ set -eu
set -o pipefail
python3 -m venv /usr/glean
# glean requires PBR to install. We explicitly pip install it to avoid
# SNI problems with pypi.org on older distros.
/usr/glean/bin/pip install pbr
/usr/glean/bin/pip install /tmp/glean.git
mkdir -p /usr/local/bin


+ 3
- 0
diskimage_builder/elements/simple-init/install.d/simple-init-source-install/40-glean View File

@ -22,6 +22,9 @@ set -eu
set -o pipefail
python3 -m venv /usr/glean
# glean requires PBR to install. We explicitly pip install it to avoid
# SNI problems with pypi.org on older distros.
/usr/glean/bin/pip install pbr
/usr/glean/bin/pip install glean
mkdir -p /usr/local/bin


Loading…
Cancel
Save