Browse Source

Add dependency on yamllint

dib-lint requires yamllint now, so we need to depend on it.

Change-Id: Iccd2cdbb04bd9b429d8d19b31ff3b10cdd568e15
tags/2.37.3
Monty Taylor 1 month ago
parent
commit
e85c2a6f03
3 changed files with 7 additions and 3 deletions
  1. +5
    -0
      releasenotes/notes/yamllint-c07fd31780ec8d10.yaml
  2. +2
    -1
      requirements.txt
  3. +0
    -2
      test-requirements.txt

+ 5
- 0
releasenotes/notes/yamllint-c07fd31780ec8d10.yaml View File

@@ -0,0 +1,5 @@
---
fixes:
- |
A dependency on ``yamllint`` was added because it is now
required by dib-lint.

+ 2
- 1
requirements.txt View File

@@ -8,5 +8,6 @@ pbr!=2.1.0,>=2.0.0 # Apache-2.0
PyYAML>=3.12 # MIT
six>=1.10.0 # MIT
stevedore>=1.20.0 # Apache-2.0
# NOTE(ianw) in here because dib-lint uses flake8
# NOTE(ianw) in here because dib-lint uses flake8 and yamllint
flake8<4.0.0,>=3.6.0 # MIT
yamllint>=1.23.0

+ 0
- 2
test-requirements.txt View File

@@ -12,5 +12,3 @@ testrepository>=0.0.18 # Apache-2.0/BSD
testtools>=2.2.0 # MIT

coverage!=4.4,>=4.0 # Apache-2.0

yamllint>=1.23.0

Loading…
Cancel
Save