Browse Source

Fix failure in pip element

A lack of space between package names was causing apt to fail.

[0] I2b75afd310f009ae8614f6ca75bb984b56d25c45

Change-Id: Ia7e005c2f583037ee44a3c364e3b8d79d51e03a2
changes/23/822223/1
Dr. Jens Harbott 5 months ago
parent
commit
f884b626b2
  1. 2
      diskimage_builder/elements/pip-and-virtualenv/install.d/pip-and-virtualenv-source-install/04-install-pip

2
diskimage_builder/elements/pip-and-virtualenv/install.d/pip-and-virtualenv-source-install/04-install-pip vendored

@ -265,7 +265,7 @@ else
# time and you had to use "python -m venv". Since then virtualenv
# has gained 3.4 support so the pip install below will work
if [[ ${DIB_PYTHON_VERSION} == 3 ]]; then
packages+="python3-pip python3-virtualenv"
packages+=" python3-pip python3-virtualenv"
fi
apt-get -y install $packages

Loading…
Cancel
Save