Remove py 3.6 support and update jobs

Although we're not on the OpenStack release schedule as such, Zed
cycle is dropping 3.6/3.7 support.  This means it seems like as good a
time as any to also update ourselves to this regime.  One important
dependency to think about is nodepool, but that is already >3.8 only
so we will be in sync there.

This also changes dib jobs to run using the zed template and adapts
the bindep file to handle Ubuntu Jammy.

[1] https://governance.openstack.org/tc/reference/runtimes/zed.html

Change-Id: Ibdbcf459608711ac64e7fefb1707f6708d68e750
Co-Authored-By: Jay Faulkner <jay@jvf.cc>
Co-Authored-By: Jens Harbott <frickler@offenerstapel.de>
Co-Authored-By: Ian Wienand <iwienand@redhat.com>
changes/29/836229/7
Jens Harbott 10 months ago committed by Jay Faulkner
parent 70e90e1755
commit fe0e5324d4

@ -7,7 +7,7 @@
# NOTE(ianw): 2020-05-29 jobs are unstable; see
# https://bugs.launchpad.net/tripleo/+bug/1879766
- tripleo-buildimage-jobs-centos-8
- openstack-python3-wallaby-jobs
- openstack-python3-zed-jobs
check:
jobs:
- openstack-tox-pylint

@ -14,17 +14,17 @@ git
squashfs-tools [!platform:suse]
squashfs [platform:suse]
zypper [!platform:debian-stretch !platform:redhat !platform:ubuntu-trusty !platform:ubuntu-bionic !platform:ubuntu-focal]
zypper [!platform:debian-stretch !platform:redhat !platform:ubuntu-trusty !platform:ubuntu-bionic !platform:ubuntu-focal !platform:ubuntu-jammy]
gnupg2 [!platform:redhat !platform:ubuntu-trusty !platform:suse]
# ubuntu
apt-transport-https [platform:dpkg]
inetutils-ping [platform:dpkg]
python-lzma [platform:dpkg !platform:ubuntu-focal !platform:debian-bullseye]
python-lzma [platform:dpkg !platform:ubuntu-focal !platform:ubuntu-jammy !platform:debian-bullseye]
qemu-utils [platform:dpkg]
rpm [platform:dpkg]
uuid-runtime [platform:dpkg]
yum-utils [platform:dpkg !platform:ubuntu-focal !platform:debian-bullseye]
yum-utils [platform:dpkg !platform:ubuntu-focal !platform:ubuntu-jammy !platform:debian-bullseye]
dnf [platform:debian-bullseye]
debootstrap [platform:dpkg]
zstd [platform:dpkg]

@ -0,0 +1,3 @@
---
upgrade:
- This release removes support for Python releases before 3.8

@ -12,12 +12,10 @@ classifier =
License :: OSI Approved :: Apache Software License
Operating System :: POSIX :: Linux
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3.8
Programming Language :: Python :: 3.9
Environment :: Console
python_requires = >=3.6
python_requires = >=3.8
[files]
packages =

Loading…
Cancel
Save