Browse Source

Merge "[ussuri][goal] Drop python 2.7 support and testing"

changes/38/707638/1
Zuul Gerrit Code Review 2 weeks ago
parent
commit
18aba3429d
4 changed files with 7 additions and 4 deletions
  1. +0
    -1
      .zuul.yaml
  2. +6
    -0
      releasenotes/notes/drop-py-2-7-a4b96d486289a772.yaml
  3. +0
    -2
      setup.cfg
  4. +1
    -1
      tox.ini

+ 0
- 1
.zuul.yaml View File

@@ -40,7 +40,6 @@
templates:
- check-requirements
- openstack-lower-constraints-jobs
- openstack-python-jobs
- openstack-python3-ussuri-jobs
- publish-openstack-docs-pti
check:


+ 6
- 0
releasenotes/notes/drop-py-2-7-a4b96d486289a772.yaml View File

@@ -0,0 +1,6 @@
---
upgrade:
- |
Python 2.7 support has been dropped. Last release of ec2-api
to support python 2.7 is OpenStack Train. The minimum version of Python now
supported by ec2-api is Python 3.6.

+ 0
- 2
setup.cfg View File

@@ -14,8 +14,6 @@ classifier =
License :: OSI Approved :: Apache Software License
Operating System :: POSIX :: Linux
Programming Language :: Python
Programming Language :: Python :: 2
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7


+ 1
- 1
tox.ini View File

@@ -1,6 +1,6 @@
[tox]
minversion = 3.1
envlist = pep8,py27,py37,docs,api-ref
envlist = pep8,py37,docs,api-ref
skipsdist = True
ignore_basepython_conflict = True



Loading…
Cancel
Save