You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
ec2-api/requirements.txt

38 lines
1.3 KiB

# Requirements lower bounds listed here are our best effort to keep them up to
# date but we do not test them so no guarantee of having them all correct. If
# you find any incorrect lower bounds, let us know or propose a fix.
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
botocore>=1.9.7 # Apache-2.0
cryptography>=2.1.4 # BSD/Apache-2.0
eventlet>=0.20.0 # MIT
greenlet>=0.4.13 # MIT
httplib2>=0.10.3 # MIT
keystoneauth1>=3.14.0 # Apache-2.0
lxml>=4.1.1 # BSD
oslo.cache>=1.29.0 # Apache-2.0
oslo.config>=5.2.0 # Apache-2.0
oslo.concurrency>=3.26.0 # Apache-2.0
oslo.context>=2.20.0 # Apache-2.0
oslo.db>=4.40.0 # Apache-2.0
oslo.log>=3.37.0 # Apache-2.0
oslo.serialization>=2.25.0 # Apache-2.0
oslo.service>=1.30.0 # Apache-2.0
oslo.utils>=3.36.0 # Apache-2.0
Paste>=2.0.3 # MIT
PasteDeploy>=1.5.2 # MIT
pbr>=3.1.1 # Apache-2.0
python-cinderclient>=3.5.0 # Apache-2.0
python-glanceclient>=2.16.0 # Apache-2.0
python-keystoneclient>=3.15.0 # Apache-2.0
python-neutronclient>=6.7.0 # Apache-2.0
python-novaclient>=10.1.0 # Apache-2.0
python-openstackclient>=3.14.0 # Apache-2.0
Routes>=2.4.1 # MIT
SQLAlchemy>=1.2.5 # MIT
sqlalchemy-migrate>=0.11.0 # Apache-2.0
WebOb>=1.7.4 # MIT