Upgrade pylint to a new version that works with python3.7

The pylint and astroid version should be specified for python3.7
pylint==2.3.1
astriod==2.1.0

Change-Id: I5aa7676b18beafc50d3f773f488e5dbe30e62035
changes/51/692251/1
caihui 3 years ago
parent bb6e6dfd49
commit 99d4ece384

@ -44,7 +44,7 @@ symbols=no
# --enable=similarities". If you want to run only the classes checker, but have
# no Warning level messages displayed, use"--disable=all --enable=classes
# --disable=W"
disable=W,C,R,E1002,no-member
disable=W,C,R,E1002,no-member,assignment-from-none
[REPORTS]

@ -2,7 +2,7 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
flake8<2.6.0,>=2.5.4 # MIT
pylint==1.9.2 # GPLv2
#pylint==1.9.2 # GPLv2
hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
mock>=2.0.0 # BSD
@ -15,3 +15,7 @@ testtools>=2.2.0 # MIT
os-api-ref>=1.4.0 # Apache-2.0
reno>=2.5.0 # Apache-2.0
openstackdocstheme>=1.18.1 # Apache-2.0
astroid==1.6.5;python_version<"3.0" # LGPLv2.1
astroid==2.1.0;python_version>="3.0" # LGPLv2.1
pylint==1.9.2;python_version<"3.0" # GPLv2
pylint==2.3.1;python_version>="3.0" # GPLv2

Loading…
Cancel
Save