Browse Source

Use botocore instead of boto3

boto which is the old version of boto3 is already in the project
requirements, it's used by ec2-api and some other projects, and
they do not have plan to migrate boto to boto3 in pike. Add boto3
to requirements will make requirements have old and new library
at the same time. So use botocore instead of boto3 in S3 driver.

Change-Id: I777b2631b0014ba44e8fd2c409a168fd9a6ef3d2
Pengju Jiao 1 year ago
parent
commit
6211da5ceb
1 changed files with 2 additions and 2 deletions
  1. 2
    2
      specs/pike/approved/s3_driver_support.rst

+ 2
- 2
specs/pike/approved/s3_driver_support.rst View File

@@ -51,8 +51,8 @@ Related docs:
51 51
 Amazon S3 REST API Introduction
52 52
 * http://docs.aws.amazon.com/AmazonS3/latest/API/Welcome.html
53 53
 
54
-The python client module that could be used is boto3
55
-* https://github.com/boto/boto3
54
+The python client module that could be used is botocore
55
+* https://github.com/boto/botocore
56 56
 
57 57
 Data model impact
58 58
 -----------------

Loading…
Cancel
Save