Sync Sphinx requirement

1. Sync sphinx dependency with global requirements. It caps python 2 since
sphinx 2.0 no longer supports Python 2.7.
2. Update some URLs to latest
3. Bump the keystoneauth1 to 3.14.0 to fix the gate[0]

[0]: http://logs.openstack.org/40/666040/4/check/openstack-tox-lower-constraints/063a064/job-output.txt.gz#_2019-06-18_16_35_28_185448

Change-Id: I5cb981175922df52ae55961109c904f6ecf94d24
changes/40/666040/5 train-em
jacky06 4 years ago
parent 7509ca245a
commit 1f06dacd90

@ -116,4 +116,4 @@ Source Code
===========
The project source code repository is located at:
https://git.openstack.org/cgit/openstack/freezer-web-ui
https://opendev.org/openstack/freezer-web-ui/

@ -1,7 +1,9 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2,<2.0.0;python_version=='2.7' # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2;python_version>='3.4' # BSD
sphinxcontrib-apidoc>=0.2.0 # BSD
openstackdocstheme>=1.18.1 # Apache-2.0
reno>=2.5.0 # Apache-2.0

@ -20,7 +20,7 @@ idna==2.6
imagesize==1.0.0
iso8601==0.1.12
Jinja2==2.10
keystoneauth1==3.11.0
keystoneauth1==3.14.0
linecache2==1.0.0
logilab-common==1.4.1
MarkupSafe==1.0

@ -1,6 +1,7 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
@ -10,5 +11,6 @@ pylint==1.4.5 # GPLv2
testrepository>=0.0.18 # Apache-2.0/BSD
testtools>=2.2.0 # MIT
unittest2>=1.1.0 # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2,<2.0.0;python_version=='2.7' # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2;python_version>='3.4' # BSD
oslosphinx>=4.7.0 # Apache-2.0

Loading…
Cancel
Save