Cleanup py27 support

Make a few cleanups:
- Remove python 2.7 stanza from setup.py
- Add requires on python >= 3.6 to setup.cfg so that pypi and pip
  know about the requirement
- Remove obsolete sections from setup.cfg:
  * Wheel is not needed for python 3 only repo
  * Some other sections are obsolete
- Update classifiers
- Update requirements, no need for python_version anymore
- Remove unused oslosphinx requirement

Change-Id: I845d02c5fb7cf57beb3628821156bff7310733ca
changes/35/717535/1 ussuri-em
Andreas Jaeger 3 years ago
parent 7f03af4887
commit e599248661

@ -2,7 +2,7 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
sphinx!=1.6.6,!=1.6.7,>=1.6.2;python_version>='3.4' # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
sphinxcontrib-apidoc>=0.2.0 # BSD
openstackdocstheme>=1.18.1 # Apache-2.0
reno>=2.5.0 # Apache-2.0

@ -31,7 +31,6 @@ netaddr==0.7.19
oslo.config==5.2.0
oslo.i18n==3.20.0
oslo.log==3.36.0
oslosphinx==4.7.0
pbr==3.1.1
pep8==1.5.7
prettytable==0.7.2

@ -6,6 +6,7 @@ summary = Freezer - Backup as a Service User Interface
description-file = README.rst
home-page = https://github.com/openstack/freezer-web-ui
license = Apache-2
python-requires = >=3.6
classifier =
Development Status :: 5 - Production/Stable
Environment :: OpenStack
@ -17,6 +18,8 @@ classifier =
Operating System :: OS Independent
Operating System :: POSIX :: Linux
Programming Language :: Python
Programming Language :: Python :: Implementation :: CPython
Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
@ -30,11 +33,3 @@ keywords =
[files]
packages =
disaster_recovery
[build_sphinx]
source-dir = doc/source
build-dir = doc/build
all_files = 1
[bdist_wheel]
universal = 1

@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
# In python < 2.7.4, a lazy loading of package `pbr` will break
# setuptools if some other modules registered functions in `atexit`.
# solution from: http://bugs.python.org/issue15881#msg170215
try:
import multiprocessing # noqa
except ImportError:
pass
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)

@ -7,14 +7,10 @@ hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
mock>=2.0.0 # BSD
oslo.config>=5.2.0 # Apache-2.0
#pylint==1.4.5 # GPLv2
testrepository>=0.0.18 # Apache-2.0/BSD
testtools>=2.2.0 # MIT
unittest2>=1.1.0 # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2;python_version>='3.4' # BSD
oslosphinx>=4.7.0 # Apache-2.0
astroid==1.6.5;python_version<"3.0" # LGPLv2.1
astroid==2.1.0;python_version>="3.0" # LGPLv2.1
pylint==1.9.2;python_version<"3.0" # GPLv2
pylint==2.3.1;python_version>="3.0" # GPLv2
sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
astroid==2.1.0 # LGPLv2.1
pylint==2.3.1 # GPLv2

Loading…
Cancel
Save