Browse Source

Fix line wrapping

Some linewrapping in code blocs actually breaks the code

Change-Id: Ibc8573c2ecaf6c9b780864f8f9878e11b06c2584
Aurélien Joga 2 years ago
parent
commit
619d78a4b4

+ 1
- 1
plugindocs/fuel-plugin-sdk-guide/create-environment/autotests.rst View File

@@ -53,7 +53,7 @@ Follow these additional guidelines on creating and formating your own tests:
53 53
 
54 54
    .. code-block:: console
55 55
 
56
-      ./utils/jenkins/system_tests.sh -t test -w\
56
+      ./utils/jenkins/system_tests.sh -t test -w \
57 57
       $(pwd) -j fuelweb_test -i $ISO_PATH -o --group=setup
58 58
 
59 59
 #. For additional information, type:

+ 3
- 3
plugindocs/fuel-plugin-sdk-guide/create-environment/plugin-ci.rst View File

@@ -43,7 +43,7 @@ and deploying new changes.
43 43
           set -e
44 44
           set -o pipefail
45 45
 
46
-          find . -name '*.pp' | xargs -P1 -L1 puppet parser\
46
+          find . -name '*.pp' | xargs -P1 -L1 puppet parser \
47 47
           validate --verbose
48 48
           find . -name '*.pp' | xargs -P1 -L1 puppet-lint \
49 49
             --fail-on-warnings \
@@ -55,9 +55,9 @@ and deploying new changes.
55 55
             --no-autoloader_layout-check \
56 56
             --no-class_inherits_from_params_class-check \
57 57
             --no-documentation-check \
58
-            --no-arrow_alignment-check\
58
+            --no-arrow_alignment-check \
59 59
             --no-case_without_default-check
60
-          find . -name '*.erb' | xargs -P1 -L1 -I '%'\
60
+          find . -name '*.erb' | xargs -P1 -L1 -I '%' \
61 61
           erb -P -x -T '-' % | ruby -c
62 62
           fpb --check  ./
63 63
 

+ 10
- 9
plugindocs/fuel-plugin-sdk-guide/create-environment/plugin-ci/plugin-ci-job-examples.rst View File

@@ -19,12 +19,13 @@ for plugins.
19 19
      ${BUILD_NUMBER}
20 20
      export VENV_PATH='/home/jenkins/\
21 21
      venv-nailgun-tests-2.9'
22
-     YOUR_PLUGIN_PATH="$(ls ./*rpm)"\#Change\
23
-     this to appropriate fuel-qa variable for your plugin
24
-     export YOUR_PLUGIN_PATH#
22
+     # Change this to appropriate fuel-qa 
23
+     # variable for your plugin
24
+     YOUR_PLUGIN_PATH="$(ls ./*rpm)"
25
+     export YOUR_PLUGIN_PATH
25 26
 
26
-     sh -x "${SYSTEM_TESTS}" -w "${WORKSPACE}" -V\
27
-     "${VENV_PATH}" -i "${ISO_PATH}" -t test -o\
27
+     sh -x "${SYSTEM_TESTS}" -w "${WORKSPACE}" -V \
28
+     "${VENV_PATH}" -i "${ISO_PATH}" -t test -o \
28 29
      --group="${TEST_GROUP}"
29 30
 
30 31
 * prepare_env.sh:
@@ -42,7 +43,7 @@ for plugins.
42 43
       REQS_PATH="${WORKSPACE}/fuel-qa/\
43 44
       fuelweb_test/requirements.txt"
44 45
 
45
-      virtualenv --system-site-packages\
46
+      virtualenv --system-site-packages \
46 47
       "${VENV_PATH}"
47 48
       source "${VENV_PATH}/bin/activate"
48 49
       pip install -r "${REQS_PATH}" --upgrade
@@ -59,11 +60,11 @@ for plugins.
59 60
       #!/bin/bash
60 61
       set -ex
61 62
 
62
-      find . -name '*.erb' -print 0 | xargs -0 -P1\
63
+      find . -name '*.erb' -print 0 | xargs -0 -P1 \
63 64
       -I '%' erb -P -x -T '-' % | ruby -c
64
-      find . -name '*.pp' -print 0| xargs -0 -P1\
65
+      find . -name '*.pp' -print 0| xargs -0 -P1 \
65 66
       puppet parser validate --verbose
66
-      find . -name '*.pp' -print 0| xargs -0 -P1\
67
+      find . -name '*.pp' -print 0| xargs -0 -P1 \
67 68
       puppet-lint \
68 69
         --fail-on-warnings \
69 70
         --with-context \

+ 2
- 2
plugindocs/fuel-plugin-sdk-guide/create-environment/plugin-ci/plugin-ci-workflow.rst View File

@@ -17,8 +17,8 @@ The Fuel developers team recommends that you follow this CI workflow:
17 17
 
18 18
      .. code-block:: console
19 19
 
20
-        $ fuel-main/utils/jenkins/system_tests -t test -j\
21
-        dis_fuelweb_test -i (path to downloaded Fuel-ISO)\
20
+        $ fuel-main/utils/jenkins/system_tests -t test -j \
21
+        dis_fuelweb_test -i (path to downloaded Fuel-ISO) \
22 22
         -o --group=setup -V ${VIRTUAL_ENV} -k
23 23
 
24 24
    * Create or restore the required empty VMs from snapshots.

+ 3
- 3
plugindocs/fuel-plugin-sdk-guide/create-plugin/install-plugin-builder.rst View File

@@ -14,7 +14,7 @@ You must use the Fuel Master node as the build environment.
14 14
 
15 15
    .. code-block:: console
16 16
 
17
-      yum install -y git python-mako createrepo dpkg-devel dpkg-dev rpm\
17
+      yum install -y git python-mako createrepo dpkg-devel dpkg-dev rpm \
18 18
       rpm-build
19 19
 
20 20
 #. Clone the Fuel Plugin Builder repository:
@@ -38,7 +38,7 @@ You must use the Fuel Master node as the build environment.
38 38
 
39 39
    The ``tasks.yaml`` file is required for the plugin to build, even if
40 40
    the file is empty.
41
-   
41
+
42 42
    .. note:: If the plugin metadata does not specify the same version of
43 43
              OpenStack as the one supported by the Fuel Master node,
44 44
              on which the plugin is installed, you will not see any
@@ -67,4 +67,4 @@ You must use the Fuel Master node as the build environment.
67 67
       print pkg_resources.get_distribution\
68 68
       ("fuel-plugin-builder").version'
69 69
   
70
-   This should display ``4.0.0``.
70
+   This should display ``4.0.0``.

Loading…
Cancel
Save