Browse Source

Add OS_IDENTITY_API_VERSION to the openrc file

In order to use "domain" subcommand in OpenStack Client,
We need to specify keystone api verion with
environment variable called "OS_IDENTITY_API_VERSION".

Closes-Bug: #1547069
Change-Id: I4a84c2f72e82883bf484ff4198f44f7ff6c70e67
changes/68/332068/1
Yuki Nishiwaki 5 years ago
parent
commit
679a07354d
1 changed files with 1 additions and 0 deletions
  1. +1
    -0
      deployment/puppet/osnailyfacter/templates/openrc.erb

+ 1
- 0
deployment/puppet/osnailyfacter/templates/openrc.erb View File

@ -9,6 +9,7 @@ export OS_PROJECT_NAME='<%= @admin_tenant.gsub(/'/){ %q(\') } %>'
export OS_USERNAME='<%= @admin_user.gsub(/'/){ %q(\') } %>'
export OS_PASSWORD='<%= @admin_password.gsub(/'/){ %q(\') } %>'
export OS_AUTH_URL='<%= @auth_url %>'
export OS_IDENTITY_API_VERSION=3
export OS_DEFAULT_DOMAIN='Default'
export OS_USER_DOMAIN_NAME='Default'
export OS_PROJECT_DOMAIN_NAME='Default'


Loading…
Cancel
Save