Browse Source

Execute neutron db fixes for 9.0 seed release

Neutron contains broken migrations between 7-8 release which
leads to unavailable floating ips. Execute fix for 9.0 release too
because we do not have 9.1 release value in nailgun db.

Change-Id: Ia57f4fbc141469fe2af2f2ff948d5fbcd75362dc
Closes-bug:1644190
changes/31/401931/1
Vladimir Khlyunev 3 years ago
parent
commit
ba4b7497c7
1 changed files with 2 additions and 2 deletions
  1. +2
    -2
      deployment/puppet/octane_tasks/graphs/seed/upgrade-db.yaml

+ 2
- 2
deployment/puppet/octane_tasks/graphs/seed/upgrade-db.yaml View File

@@ -90,7 +90,7 @@
puppet_modules: /etc/fuel/octane/puppet:/etc/puppet/modules
timeout: 360

# Should be applied only on 6.0-7.0 -> 9.1+
# Should be applied only on 6.0-7.0 -> 9.0+
- id: neutron_migrations_for_fuel_8
type: puppet
version: 2.1.0
@@ -99,7 +99,7 @@
required_for: []
condition:
# Double slashes so that Python's YAML parser doesn't try to escape \.
yaql_exp: "$.upgrade.relation_info.orig_cluster_version =~ '[6-7]\\.[0-1]' and $.upgrade.relation_info.seed_cluster_version =~ '9\\.[1-9]'"
yaql_exp: "$.upgrade.relation_info.orig_cluster_version =~ '[6-7]\\.[0-1]' and $.upgrade.relation_info.seed_cluster_version =~ '9\\.[0-9]'"
parameters:
puppet_manifest: /etc/fuel/octane/puppet/octane_tasks/modular/neutron_migrations_for_fuel_8.pp
puppet_modules: /etc/fuel/octane/puppet:/etc/puppet/modules


Loading…
Cancel
Save