Browse Source

Sync with global requirements

Sync with global requirements:
https://github.com/openstack/requirements/blob/master/global-requirements.txt

Change-Id: I8cf33437f9cd2932c595cf7a78ab705ab4a9552c
Alexey Stepanov 2 years ago
parent
commit
1b0efcc3b4
1 changed files with 30 additions and 30 deletions
  1. 30
    30
      requirements.txt

+ 30
- 30
requirements.txt View File

@@ -1,33 +1,33 @@
1
-oslo.config>=2.3.0
1
+oslo.config>=3.14.0  # Apache-2.0
2 2
 
3
-aodhclient>=0.1.0
4
-python-cinderclient>=1.3.1
5
-python-ceilometerclient>=1.5.0
6
-python-keystoneclient>=1.6.0,!=1.8.0
7
-python-muranoclient>=0.7.1
8
-python-novaclient>=2.29.0,!=2.33.0
9
-python-neutronclient>=2.6.0
10
-python-heatclient>=0.3.0
11
-python-glanceclient>=0.18.0
12
-python-saharaclient>=0.10.0
3
+aodhclient>=0.5.0  # Apache-2.0
4
+python-cinderclient>=1.6.0,!=1.7.0,!=1.7.1  # Apache-2.0
5
+python-ceilometerclient>=2.5.0  # Apache-2.0
6
+python-keystoneclient>=2.0.0,!=2.1.0  # Apache-2.0
7
+python-muranoclient>=0.8.2  # Apache-2.0
8
+python-novaclient>=2.29.0,!=2.33.0  # Apache-2.0
9
+python-neutronclient>=5.1.0  # Apache-2.0
10
+python-heatclient>=1.4.0  # Apache-2.0
11
+python-glanceclient>=2.3.0,!=2.4.0  # Apache-2.0
12
+python-saharaclient>=0.18.0  # Apache-2.0
13 13
 
14
-Babel>=1.3,!=2.3.0,!=2.3.1,!=2.3.2,!=2.3.3  # BSD
15
-paramiko>=1.13.0
16
-pbr>=1.6
17
-requests>=2.5.2,!=2.8.0
18
-unittest2
19
-PyYAML>=3.1.0
20
-testresources>=0.2.4
21
-nose
22
-SQLAlchemy>=0.9.9,<1.1.0
23
-alembic>=0.8.0
24
-amqp>=1.4.9,<2.0
25
-anyjson>=0.3.3
14
+Babel>=2.3.4  # BSD
15
+paramiko>=2.0 # LGPLv2.1+
16
+pbr>=1.6  # Apache-2.0
17
+requests>=2.10.0  # Apache-2.0
18
+unittest2  # BSD
19
+PyYAML>=3.1.0  # MIT
20
+testresources>=0.2.4  # Apache-2.0/BSD
21
+nose  # LGPL
22
+SQLAlchemy>=1.0.10,<1.1.0  # MIT
23
+alembic>=0.8.4  # MIT
24
+amqp>=1.4.0,<2.0 # LGPL
25
+anyjson>=0.3.3  # BSD
26 26
 gevent
27
-keystonemiddleware>=2.0.0,!=2.4.0
28
-kombu>=3.0.7
29
-oslo.serialization>=1.4.0
30
-oslo.utils>=2.0.0,!=2.6.0
31
-pecan>=1.0.0
32
-psycopg2>=2.5
33
-stevedore>=1.5.0
27
+keystonemiddleware>=4.0.0,!=4.1.0,!=4.5.0  # Apache-2.0
28
+kombu>=3.0.25  # BSD
29
+oslo.serialization>=1.10.0              # Apache-2.0
30
+oslo.utils>=3.16.0                       # Apache-2.0
31
+pecan>=1.0.0,!=1.0.2,!=1.0.3,!=1.0.4  # BSD
32
+psycopg2>=2.5  # LGPL/ZPL
33
+stevedore>=1.16.0  # Apache-2.0

Loading…
Cancel
Save