Browse Source

[ussuri][goal] Drop python 2.7 support and testing

OpenStack is dropping the py2.7 support in Ussuri cycle.

Complete discussion & schedule can be found in
-
http://lists.openstack.org/pipermail/openstack-discuss/2019-October/010142.html
- https://etherpad.openstack.org/p/drop-python2-support

Ussuri Communtiy-wide goal:
https://governance.openstack.org/tc/goals/selected/ussuri/drop-py27.html

Change-Id: Ia7abd5c3861978dbcbc7c72f469d19ff41032c13
Sem-Ver: api-break
tags/2.0.0^0
Hervé Beraud 2 weeks ago
parent
commit
0c5e44839c
8 changed files with 20 additions and 37 deletions
  1. +0
    -2
      .zuul.yaml
  2. +1
    -2
      doc/requirements.txt
  3. +0
    -2
      lower-constraints.txt
  4. +5
    -0
      releasenotes/notes/drop-python27-support-5757997ea990b7ca.yaml
  5. +0
    -3
      requirements.txt
  6. +3
    -5
      setup.cfg
  7. +0
    -8
      setup.py
  8. +11
    -15
      tox.ini

+ 0
- 2
.zuul.yaml View File

@@ -1,10 +1,8 @@
- project:
templates:
- check-requirements
- lib-forward-testing
- lib-forward-testing-python3
- openstack-lower-constraints-jobs
- openstack-python-jobs
- openstack-python3-ussuri-jobs
- periodic-stable-jobs
- publish-openstack-docs-pti

+ 1
- 2
doc/requirements.txt View File

@@ -1,4 +1,3 @@
sphinx!=1.6.6,!=1.6.7,>=1.6.2,<2.0.0;python_version=='2.7' # BSD
sphinx!=1.6.6,!=1.6.7,!=2.1.0,>=1.6.2;python_version>='3.4' # BSD
sphinx!=1.6.6,!=1.6.7,!=2.1.0,>=1.6.2 # BSD
openstackdocstheme>=1.20.0 # Apache-2.0
reno>=2.5.0 # Apache-2.0

+ 0
- 2
lower-constraints.txt View File

@@ -11,7 +11,6 @@ eventlet==0.18.2
extras==1.0.0
fixtures==3.0.0
flake8==2.2.4
futures==3.0.0;python_version=='2.7' or python_version=='2.6' # BSD
greenlet==0.4.10
hacking==0.10.0
imagesize==0.7.1
@@ -22,7 +21,6 @@ linecache2==1.0.0
MarkupSafe==1.0
mccabe==0.2.1
mock==2.0.0
monotonic==0.6
mox3==0.20.0
openstackdocstheme==1.18.1
os-client-config==1.28.0

+ 5
- 0
releasenotes/notes/drop-python27-support-5757997ea990b7ca.yaml View File

@@ -0,0 +1,5 @@
---
upgrade:
- |
Support for Python 2.7 has been dropped. The minimum version of Python now
supported is Python 3.6.

+ 0
- 3
requirements.txt View File

@@ -4,7 +4,4 @@

pbr!=2.1.0,>=2.0.0 # Apache-2.0
six>=1.10.0 # MIT
monotonic>=0.6;python_version<'3.3' # Apache-2.0
futures>=3.0.0;python_version=='2.7' or python_version=='2.6' # BSD
contextlib2>=0.4.0;python_version<'3.0' # PSF License
PrettyTable<0.8,>=0.7.1 # BSD

+ 3
- 5
setup.cfg View File

@@ -6,6 +6,7 @@ description-file =
author = OpenStack
author-email = openstack-discuss@lists.openstack.org
home-page = https://docs.openstack.org/futurist/latest/
python-requires = >=3.6
classifier =
Environment :: OpenStack
Intended Audience :: Information Technology
@@ -13,11 +14,11 @@ classifier =
License :: OSI Approved :: Apache Software License
Operating System :: POSIX :: Linux
Programming Language :: Python
Programming Language :: Python :: 2
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: Implementation :: CPython

[files]
packages =
@@ -27,9 +28,6 @@ packages =
directory = futurist/locale
domain = futurist

[wheel]
universal = 1

[update_catalog]
domain = futurist
output_dir = futurist/locale

+ 0
- 8
setup.py View File

@@ -16,14 +16,6 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools

# In python < 2.7.4, a lazy loading of package `pbr` will break
# setuptools if some other modules registered functions in `atexit`.
# solution from: http://bugs.python.org/issue15881#msg170215
try:
import multiprocessing # noqa
except ImportError:
pass

setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)

+ 11
- 15
tox.ini View File

@@ -1,8 +1,10 @@
[tox]
minversion = 2.0
envlist = py27,py37,pypy,pep8
minversion = 3.1.1
envlist = py37,pep8
ignore_basepython_conflict = true

[testenv]
basepython = python3
install_command = pip install {opts} {packages}
whitelist_externals = find
rm
@@ -14,17 +16,14 @@ commands =
stestr run --slowest {posargs}

[testenv:pep8]
basepython = python3
commands =
flake8
doc8 doc/source

[testenv:venv]
basepython = python3
commands = {posargs}

[testenv:cover]
basepython = python3
setenv =
PYTHON=coverage run --source $project --parallel-mode
commands =
@@ -36,33 +35,30 @@ commands =
coverage xml -o cover/coverage.xml
coverage report

[testenv:py27]
basepython = python2.7

[testenv:docs]
basepython = python3
whitelist_externals = rm
deps = -r{toxinidir}/doc/requirements.txt
commands =
rm -rf doc/build
sphinx-build -E -W -b html doc/source doc/build/html
sphinx-build -E -W --keep-going -b html doc/source doc/build/html

[testenv:debug]
basepython = python3
commands = oslo_debug_helper {posargs}

[flake8]
# E123, E125 skipped as they are invalid PEP-8.

show-source = True
ignore = E123,E125
exclude=.venv,.git,.tox,dist,doc,*lib/python*,*egg,build

[testenv:releasenotes]
basepython = python3
commands = sphinx-build -a -E -W -d releasenotes/build/doctrees -b html releasenotes/source releasenotes/build/html
whitelist_externals = rm
deps = {[testenv:docs]deps}
commands =
rm -rf releasenotes/build
sphinx-build -a -E -W -d releasenotes/build/doctrees -b html releasenotes/source releasenotes/build/html

[testenv:lower-constraints]
basepython = python3
deps =
-c{toxinidir}/lower-constraints.txt
-r{toxinidir}/test-requirements.txt

Loading…
Cancel
Save