Browse Source

Client v1 support removal update

Did not happen in Queens, lets try this again in Rocky.

Change-Id: Ib2d9f737a718353d399deb475378b1b6b9c933f0
Erno Kuvaja 1 year ago
parent
commit
c70688ce6e

+ 1
- 0
doc/source/_extra/.htaccess View File

@@ -3,3 +3,4 @@
3 3
 Redirect 301 /specs/queens/approved/glance/deprecate-registry.html /specs/queens/implemented/glance/deprecate-registry.html
4 4
 Redirect 301 /specs/queens/approved/glance/inject-automatic-metadata.html /specs/queens/implemented/glance/inject-automatic-metadata.html
5 5
 Redirect 301 /specs/queens/approved/glance/lite-spec-scrubber-refactor.html /specs/queens/implemented/glance/lite-spec-scrubber-refactor.html
6
+Redirect 301 /specs/queens/approved/python-glanceclient/deprecate-v1-support.rst /specs/rocky/approved/python-glanceclient/deprecate-v1-support.rst

+ 1
- 0
doc/test/redirect-tests.txt View File

@@ -4,3 +4,4 @@
4 4
 /specs/queens/approved/glance/deprecate-registry.html 301 /specs/queens/implemented/glance/deprecate-registry.html
5 5
 /specs/queens/approved/glance/inject-automatic-metadata.html 301 /specs/queens/implemented/glance/inject-automatic-metadata.html
6 6
 /specs/queens/approved/glance/lite-spec-scrubber-refactor.html 301 /specs/queens/implemented/glance/lite-spec-scrubber-refactor.html
7
+/specs/queens/approved/python-glanceclient/deprecate-v1-support.rst 301 /specs/rocky/approved/python-glanceclient/deprecate-v1-support.rst

+ 31
- 0
specs/rocky/approved/index.rst View File

@@ -0,0 +1,31 @@
1
+=============================
2
+Rocky Approved Specifications
3
+=============================
4
+
5
+.. toctree::
6
+   :glob:
7
+   :maxdepth: 1
8
+
9
+Rocky approved specs for Glance:
10
+
11
+.. toctree::
12
+   :glob:
13
+   :maxdepth: 1
14
+
15
+..   glance/*
16
+..   glance/image-import/*
17
+
18
+Rocky approved specs for glance_store:
19
+
20
+   There are no specs approved for glance_store for Rocky.
21
+   Please consult the :doc:`../../untargeted/index` if
22
+   you'd like to work on glance_store during the Rocky
23
+   development cycle.
24
+
25
+Rocky approved specs for python-glanceclient:
26
+
27
+.. toctree::
28
+   :glob:
29
+   :maxdepth: 1
30
+
31
+   python-glanceclient/*

specs/queens/approved/python-glanceclient/deprecate-v1-support.rst → specs/rocky/approved/python-glanceclient/deprecate-v1-support.rst View File

@@ -2,12 +2,12 @@
2 2
 Spec Lite: Deprecate Images API v1 Support
3 3
 ==========================================
4 4
 
5
-:problem: The Images API v1 is targeted to be removed in Queens, hence there
5
+:problem: The Images API v1 is targeted to be removed in Rocky, hence there
6 6
           is no reason to continue carrying v1 support in the glanceclient.
7 7
 
8
-:solution: Announce that the Queens release of the python-glanceclient will
8
+:solution: Announce that the Rocky release of the python-glanceclient will
9 9
            be the last release that will support the Images v1 API and that
10
-           support will be removed in the first major release of the Rocky
10
+           support will be removed in the first major release of the S
11 11
            cycle.
12 12
 
13 13
 :impacts: DocImpact
@@ -17,8 +17,7 @@ Spec Lite: Deprecate Images API v1 Support
17 17
                v1 was never included in "DefCore" tests.  Continued support
18 18
                would not be a good use of the team's time.
19 19
 
20
-:timeline: Q-1 milestone (week of 16 October 2017), but definitely before
21
-           the Queens release of the glanceclient at Q-3
20
+:timeline: Early Rocky cycle
22 21
 
23 22
 :link: https://blueprints.launchpad.net/python-glanceclient/+spec/deprecate-v1-support
24 23
 

+ 1
- 1
specs/rocky/index.rst View File

@@ -20,4 +20,4 @@ Rocky approved (but not implemented) specs:
20 20
    :glob:
21 21
    :maxdepth: 1
22 22
 
23
-..   approved/*
23
+   approved/*

Loading…
Cancel
Save