Update python testing as per zed cycle teting runtime

In Zed cycle, we have dropped the python 3.6/3.7[1] testing
and its support. Moving the py36 job to py3 based so that they run
on latest supported python 3. Updating the python classifier also to reflect the same.

[1] https://governance.openstack.org/tc/reference/runtimes/zed.html

Change-Id: Ida582daf7db6fb3cedb3c7e37fc512d094b37c6e
changes/53/841353/1 4.0.0
Ghanshyam Mann 9 months ago
parent aac2a83df6
commit aeee48b561

@ -54,13 +54,12 @@
- name: openstack/python-cinderclient
- job:
name: glance_store-tox-py36-cinder-tips
name: glance_store-tox-py3-cinder-tips
parent: glance_store-tox-cinder-tips-base
description: |
glance_store py36 unit tests vs. cinder masters
nodeset: ubuntu-bionic
glance_store py3 unit tests vs. cinder masters
vars:
tox_envlist: py36
tox_envlist: py3
- job:
name: glance_store-tox-keystone-tips-base
@ -73,13 +72,12 @@
- name: openstack/python-keystoneclient
- job:
name: glance_store-tox-py36-keystone-tips
name: glance_store-tox-py3-keystone-tips
parent: glance_store-tox-keystone-tips-base
description: |
glance_store py36 unit tests vs. keystone masters
nodeset: ubuntu-bionic
glance_store py3 unit tests vs. keystone masters
vars:
tox_envlist: py36
tox_envlist: py3
- job:
name: glance_store-tox-oslo-tips-base
@ -99,13 +97,12 @@
- name: openstack/stevedore
- job:
name: glance_store-tox-py36-oslo-tips
name: glance_store-tox-py3-oslo-tips
parent: glance_store-tox-oslo-tips-base
description: |
glance_store py36 unit tests vs. oslo masters
nodeset: ubuntu-bionic
glance_store py3 unit tests vs. oslo masters
vars:
tox_envlist: py36
tox_envlist: py3
- job:
name: glance_store-tox-swift-tips-base
@ -117,13 +114,12 @@
- name: openstack/python-swiftclient
- job:
name: glance_store-tox-py36-swift-tips
name: glance_store-tox-py3-swift-tips
parent: glance_store-tox-swift-tips-base
description: |
glance_store py36 unit tests vs. swift masters
nodeset: ubuntu-bionic
glance_store py3 unit tests vs. swift masters
vars:
tox_envlist: py36
tox_envlist: py3
- job:
name: glance_store-src-ceph-tempest
@ -153,7 +149,7 @@
templates:
- check-requirements
- lib-forward-testing-python3
- openstack-python3-yoga-jobs
- openstack-python3-zed-jobs
- publish-openstack-docs-pti
- release-notes-jobs-python3
check:
@ -186,11 +182,11 @@
# to define these jobs in the openstack/project-config repo.
# That would make us less agile in adjusting these tests, so we
# aren't doing that either.
- glance_store-tox-py36-cinder-tips:
- glance_store-tox-py3-cinder-tips:
branches: master
- glance_store-tox-py36-keystone-tips:
- glance_store-tox-py3-keystone-tips:
branches: master
- glance_store-tox-py36-oslo-tips:
- glance_store-tox-py3-oslo-tips:
branches: master
- glance_store-tox-py36-swift-tips:
- glance_store-tox-py3-swift-tips:
branches: master

@ -0,0 +1,5 @@
---
upgrade:
- |
Python 3.6 & 3.7 support has been dropped. The minimum version of Python now
supported is Python 3.8.

@ -6,7 +6,7 @@ description_file =
author = OpenStack
author_email = openstack-discuss@lists.openstack.org
home_page = https://docs.openstack.org/glance_store/latest/
python_requires = >=3.6
python_requires = >=3.8
classifier =
Development Status :: 5 - Production/Stable
Environment :: OpenStack
@ -18,8 +18,6 @@ classifier =
Programming Language :: Python :: Implementation :: CPython
Programming Language :: Python :: 3 :: Only
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3.8
Programming Language :: Python :: 3.9

@ -1,6 +1,6 @@
[tox]
minversion = 3.1.1
envlist = py39,py36,pep8
envlist = py39,py38,pep8
skipsdist = True
ignore_basepython_conflict = True

Loading…
Cancel
Save