Drop py36 and py37 support

We are not testing with py36 and py37 so we cannot be sure hacking works
with these versions.

Add releasenote that also mentions the previous changes in py35 and
flake8 support.

Sem-Ver: api-break
Change-Id: I798dd39afcf2f16a8660ab597b6f5bae70ab2a81
changes/70/844570/3 5.0.0
Balazs Gibizer 8 months ago committed by Dr. Jens Harbott
parent a6b9aabca5
commit 2931131b69

@ -0,0 +1,8 @@
---
upgrade:
- |
Support for Python 3.5 through 3.7 has been dropped. The minimum
supported Python version is now 3.8.
- |
``hacking`` is now compatible with ``flake8~=4.0.1``. flake8 3.x
is no longer supported.

@ -6,7 +6,7 @@ summary = OpenStack Hacking Guideline Enforcement
description_file =
README.rst
home_page = https://docs.openstack.org/hacking/latest/
python_requires = >=3.6
python_requires = >=3.8
project_urls =
Bug Tracker = https://bugs.launchpad.net/hacking
Reviews = https://review.opendev.org/q/p:openstack/hacking+status:open
@ -22,8 +22,6 @@ classifier =
Operating System :: OS Independent
Programming Language :: Python
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3.8
Programming Language :: Python :: 3.9

Loading…
Cancel
Save