Browse Source

[goal] Migrate testing to ubuntu focal

As per victoria cycle testing runtime and community goal[1]
we need to migrate upstream CI/CD to Ubuntu Focal(20.04).

Fixing:
- bug#1886298
Bump the lower constraints for required deps which added python3.8 support
in their later version.


Story: #2007865
Task: #40186

Closes-Bug: #1886298

[1] https://governance.openstack.org/tc/goals/selected/victoria/migrate-ci-cd-jobs-to-ubuntu-focal

Change-Id: Ibff0fb285694297f74d82ea8275cd6ca0b857cb2
changes/68/744068/4 4.0.0
Ghanshyam Mann 11 months ago
committed by Vishal Manchanda
parent
commit
7d4ef2057f
2 changed files with 11 additions and 5 deletions
  1. +6
    -0
      bindep.txt
  2. +5
    -5
      lower-constraints.txt

+ 6
- 0
bindep.txt View File

@ -1,3 +1,9 @@
# This is a cross-platform list tracking distribution packages needed for install and tests;
# see https://docs.openstack.org/infra/bindep/ for additional information.
libffi-dev [platform:dpkg test]
libffi-devel [platform:rpm test]
# selenium tests
firefox [selenium]
xvfb [selenium platform:dpkg]


+ 5
- 5
lower-constraints.txt View File

@ -3,14 +3,14 @@ appdirs==1.3.0
asn1crypto==0.23.0
Babel==2.3.4
cachetools==2.0.0
cffi==1.7.0
cffi==1.14.0
chardet==3.0.4
cliff==2.8.0
cmd2==0.8.0
colorama==0.3.9
contextlib2==0.4.0
coverage==4.0
cryptography==2.1
cryptography==2.7
debtcollector==1.2.0
decorator==3.4.0
deprecation==1.0
@ -40,7 +40,7 @@ keystoneauth1==3.4.0
kombu==4.0.0
linecache2==1.0.0
MarkupSafe==1.0
mccabe==0.2.1
mccabe==0.6.0
monotonic==0.6
msgpack-python==0.4.0
munch==2.1.0
@ -71,7 +71,7 @@ pika-pool==0.1.3
Pint==0.5
positional==1.2.1
prettytable==0.7.2
pycodestyle==2.3.1
pycodestyle==2.5.0
pycparser==2.18
pyinotify==0.9.6
pymongo==3.0.2
@ -89,7 +89,7 @@ python-neutronclient==6.7.0
python-novaclient==9.1.0
python-swiftclient==3.2.0
pytz==2013.6
PyYAML==3.12
PyYAML==3.13
rcssmin==1.0.6
repoze.lru==0.7
requests==2.14.2


Loading…
Cancel
Save