Browse Source

Drop nose dependencies

Horizon test setting no longer depends on nose and related stuffs.
This commit cleans up nose related dependencies.

The change was made in horizon Rocky-3,
so horizon 14.0.0.0b3 is required at least.

Change-Id: I25cb4aa6558c599d3c1e334c5281dcb6ca7e3b9f
Akihiro Motoki 8 months ago
parent
commit
be8e3372aa
3 changed files with 2 additions and 14 deletions
  1. 1
    7
      lower-constraints.txt
  2. 1
    1
      requirements.txt
  3. 0
    6
      test-requirements.txt

+ 1
- 7
lower-constraints.txt View File

@@ -18,7 +18,6 @@ Django==1.8
18 18
 django-appconf==1.0.2
19 19
 django-babel==0.5.1
20 20
 django-compressor==2.0
21
-django-nose==1.4.4
22 21
 django-pyscss==2.0.2
23 22
 doc8==0.6.0
24 23
 docutils==0.11
@@ -32,7 +31,7 @@ flake8-import-order==0.12
32 31
 futurist==1.2.0
33 32
 greenlet==0.4.10
34 33
 hacking==0.12.0
35
-horizon==14.0.0.0b1
34
+horizon==14.0.0.0b3
36 35
 idna==2.6
37 36
 iso8601==0.1.11
38 37
 Jinja2==2.10
@@ -53,11 +52,6 @@ munch==2.1.0
53 52
 netaddr==0.7.18
54 53
 netifaces==0.10.4
55 54
 nodeenv==0.9.4
56
-nose==1.3.7
57
-nose-exclude==0.3.0
58
-nosehtmloutput==0.0.3
59
-nosexcover==1.0.10
60
-openstack.nose-plugin==0.7
61 55
 openstacksdk==0.11.2
62 56
 os-client-config==1.28.0
63 57
 os-service-types==1.2.0

+ 1
- 1
requirements.txt View File

@@ -12,7 +12,7 @@ python-heatclient>=1.10.0 # Apache-2.0
12 12
 
13 13
 # This will be installed from git in OpenStack CI if the job setting
14 14
 # required-projects for horizon:
15
-horizon>=14.0.0.0b1 # Apache-2.0
15
+horizon>=14.0.0.0b3 # Apache-2.0
16 16
 
17 17
 xstatic-angular-uuid>=0.0.4.0 # MIT
18 18
 xstatic-angular-vis>=4.16.0.0 # MIT

+ 0
- 6
test-requirements.txt View File

@@ -10,15 +10,9 @@
10 10
 hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
11 11
 #
12 12
 coverage!=4.4,>=4.0 # Apache-2.0
13
-django-nose>=1.4.4 # BSD
14 13
 doc8>=0.6.0 # Apache-2.0
15 14
 flake8-import-order==0.12 # LGPLv3
16 15
 mock>=2.0.0 # BSD
17 16
 mox3>=0.20.0 # Apache-2.0
18 17
 nodeenv>=0.9.4 # BSD
19
-nose>=1.3.7 # LGPL
20
-nose-exclude>=0.3.0 # LGPL
21
-nosehtmloutput>=0.0.3 # Apache-2.0
22
-nosexcover>=1.0.10 # BSD
23
-openstack.nose-plugin>=0.7 # Apache-2.0
24 18
 testtools>=2.2.0 # MIT

Loading…
Cancel
Save