Browse Source

Updated from global requirements

Change-Id: Id1d516edc130dbff51909daab03536017a471542
changes/01/201801/7
OpenStack Proposal Bot 7 years ago
parent
commit
09c8a4c159
  1. 7
      requirements.txt
  2. 2
      setup.py
  3. 2
      test-requirements.txt

7
requirements.txt

@ -2,7 +2,7 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
pbr<2.0,>=0.11
pbr<2.0,>=1.3
Babel>=1.3
cryptography>=0.8.2 # Apache-2.0
dogpile.cache>=0.5.3
@ -26,7 +26,7 @@ oslo.policy>=0.5.0 # Apache-2.0
oslo.reports>=0.1.0 # Apache-2.0
oslo.serialization>=1.4.0 # Apache-2.0
oslo.service>=0.1.0 # Apache-2.0
oslo.utils>=1.6.0 # Apache-2.0
oslo.utils>=1.9.0 # Apache-2.0
osprofiler>=0.3.0 # Apache-2.0
oslo.versionedobjects!=0.5.0,>=0.3.0
PasteDeploy>=1.5.0
@ -49,7 +49,8 @@ python-zaqarclient>=0.1.1
PyYAML>=3.1.0
qpid-python;python_version=='2.7'
requests>=2.5.2
Routes!=2.0,!=2.1,>=1.12.3
Routes!=2.0,!=2.1,>=1.12.3;python_version=='2.7'
Routes!=2.0,>=1.12.3;python_version!='2.7'
six>=1.9.0
SQLAlchemy<1.1.0,>=0.9.7
sqlalchemy-migrate>=0.9.6

2
setup.py

@ -25,5 +25,5 @@ except ImportError:
pass
setuptools.setup(
setup_requires=['pbr'],
setup_requires=['pbr>=1.3'],
pbr=True)

2
test-requirements.txt

@ -13,7 +13,7 @@ mox>=0.5.3
mox3>=0.7.0
PyMySQL>=0.6.2 # MIT License
oslosphinx>=2.5.0 # Apache-2.0
oslotest>=1.5.1 # Apache-2.0
oslotest>=1.7.0 # Apache-2.0
paramiko>=1.13.0
psycopg2
sphinx!=1.2.0,!=1.3b1,<1.3,>=1.1.2

Loading…
Cancel
Save