Do not verify requirements on extension loading

The heat gate is broken due to other libraries pinning
on pbr<1.0

Stevedore extension loading currently has verify_requirements=True.
This change removes this to use the default of False. Loading extensions
is likely the wrong place to be enforcing requirements versions of
libraries that heat depends on, so lets not do it.

This is likely to also improve heat robustness for deployments with
inconsistent dependencies, not just this current heat breakage.

Change-Id: Ifee37e00412e824eead9ba1435ea5a328ff3df58
Closes-Bug: #1458399
changes/87/185287/4
Steve Baker 7 years ago
parent 60300b0149
commit 4894441ebc
  1. 3
      heat/engine/clients/__init__.py
  2. 3
      heat/engine/resources/__init__.py
  3. 1
      heat/engine/template.py

@ -163,8 +163,7 @@ def initialise():
_mgr = extension.ExtensionManager(
namespace='heat.clients',
invoke_on_load=False,
verify_requirements=True)
invoke_on_load=False)
def list_opts():

@ -37,8 +37,7 @@ def _register_stack_lifecycle_plugins(env, type_pairs):
def _get_mapping(namespace):
mgr = extension.ExtensionManager(
namespace=namespace,
invoke_on_load=False,
verify_requirements=True)
invoke_on_load=False)
return [[name, mgr[name].plugin] for name in mgr.names()]

@ -55,7 +55,6 @@ def _get_template_extension_manager():
return extension.ExtensionManager(
namespace='heat.templates',
invoke_on_load=False,
verify_requirements=True,
on_load_failure_callback=raise_extension_exception)

Loading…
Cancel
Save