Browse Source

Provide install_command to pip install with upper-constraints

SQLAlchemy latest (1.4.27) installed with docs job breaks it.

Change-Id: Ida63e1d865dc0b2ac6a13594455962f53068c931
(cherry picked from commit 7f15b14d80)
changes/55/818655/2 victoria-em
Brendan Shephard 6 months ago
parent
commit
cbe9be5e76
  1. 1
      tox.ini

1
tox.ini

@ -9,6 +9,7 @@ basepython = python3
setenv = VIRTUAL_ENV={envdir}
PYTHONWARNINGS=default::DeprecationWarning
OS_TEST_PATH=heat/tests
install_command = pip install -c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/victoria} {opts} {packages}
usedevelop = True
deps = -c{env:TOX_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/victoria}
-r{toxinidir}/requirements.txt

Loading…
Cancel
Save