Browse Source

Update Python 3 test runtimes for Train

This goal is to implement the process set out in the 2018-10-24 Python
Update Process TC resolution[1], for the Train cycle to ensure unit
testing is in place for all of the Tested Runtimes for Train[2].
In practice, this generally means adding unit tests for Python 3.7 and dropping
unit tests for Python 3.5. Using the Zuul template for Train will ensure that
all projects that support Python3 will be tested against the agreed runtime
versions, and make it easier to update them in future.

[1]https://governance.openstack.org/tc/resolutions/20181024-python-update-process.html
[2]https://governance.openstack.org/tc/reference/runtimes/train.html

Change-Id: I62abb218bb314345dd7da1cbf9133d10db9696ff
Depends-On: https://review.opendev.org/#/c/641878/
changes/34/657934/2
ZhongShengping 3 years ago
parent
commit
f66dac5c63
  1. 2
      .zuul.yaml
  2. 1
      setup.cfg
  3. 2
      tox.ini

2
.zuul.yaml

@ -106,7 +106,7 @@
- openstack-cover-jobs
- openstack-lower-constraints-jobs
- openstack-python-jobs
- openstack-python36-jobs
- openstack-python3-train-jobs
- publish-openstack-docs-pti
- check-requirements
- release-notes-jobs-python3

1
setup.cfg

@ -17,6 +17,7 @@ classifier =
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
[files]
data_files =

2
tox.ini

@ -1,5 +1,5 @@
[tox]
envlist = py36,py27,pep8
envlist = py36,py37,py27,pep8
minversion = 1.6
skipsdist = True

Loading…
Cancel
Save