Browse Source

Cap bandit for python 2.7 env

bandit 1.6.3 supports only python>=3.5 and rokcy jobs with python 2.7
are broken when bandit 1.6.3 is being installed.
bandit <1.6.3 supports python 2.7.
We have no constraint for test only libraries so we need to cap it.

This change is only required in rocky or older releases,
so it is directly proposed to stable/rocky.

doc/requirements.txt also needs to be updated to pass the requirements-check
job as global-requirements.txt in the requirements repo was updated
after the rocky release.

Depends-On: https://review.opendev.org/c/openstack/requirements/+/766426
Change-Id: Iae6c7abecd1aec9db00c14f29fd98dd1a8682084
changes/29/766129/5
Akihiro Motoki 5 months ago
parent
commit
019f7ebaf4
2 changed files with 3 additions and 2 deletions
  1. +2
    -1
      doc/requirements.txt
  2. +1
    -1
      test-requirements.txt

+ 2
- 1
doc/requirements.txt View File

@ -7,7 +7,8 @@
# be installed in a specific order.
openstackdocstheme>=1.18.1 # Apache-2.0
reno>=2.5.0 # Apache-2.0
sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD
sphinx>=1.6.2,!=1.6.6,!=1.6.7,<2.0.0;python_version=='2.7' # BSD
sphinx>=1.6.2,!=1.6.6,!=1.6.7;python_version>='3.4' # BSD
# The below is rewquired to build testing module reference
mock>=2.0.0 # BSD

+ 1
- 1
test-requirements.txt View File

@ -9,7 +9,7 @@
# Hacking should appear first in case something else depends on pep8
hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
#
bandit>=1.4.0 # Apache-2.0
bandit>=1.4.0,<1.6.3 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
doc8>=0.6.0 # Apache-2.0
flake8-import-order==0.12 # LGPLv3


Loading…
Cancel
Save