Browse Source

Cap bandit for python 2.7 env

bandit 1.6.3 supports only python>=3.5 and stein jobs with python 2.7
are broken when bandit 1.6.3 is being installed.
bandit <1.6.3 supports python 2.7.
We have no constraint for test only libraries so we need to cap it.

doc/requirements.txt and lower-constraints.txt also needs to be
updated to pass the requirements-check and lower-constarints-job
respectively.

Change-Id: Ia8c69501a1362cb08344aa50d00ed184e9f3d49f
changes/03/768403/3
manchandavishal 4 months ago
parent
commit
0ce59e53a0
3 changed files with 7 additions and 7 deletions
  1. +2
    -2
      doc/requirements.txt
  2. +4
    -4
      lower-constraints.txt
  3. +1
    -1
      test-requirements.txt

+ 2
- 2
doc/requirements.txt View File

@ -7,8 +7,8 @@
# be installed in a specific order.
openstackdocstheme>=1.18.1 # Apache-2.0
reno>=2.5.0 # Apache-2.0
sphinx!=1.6.6,!=1.6.7,>=1.6.2,<2.0.0;python_version=='2.7' # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.2;python_version>='3.4' # BSD
sphinx>=1.6.2,!=1.6.6,!=1.6.7,<2.0.0;python_version=='2.7' # BSD
sphinx>=1.6.2,!=1.6.6,!=1.6.7;python_version>='3.4' # BSD
# The below is rewquired to build testing module reference
mock>=2.0.0 # BSD

+ 4
- 4
lower-constraints.txt View File

@ -29,11 +29,11 @@ eventlet==0.18.2
extras==1.0.0
fasteners==0.7.0
fixtures==3.0.0
flake8==2.5.5
flake8==2.6.2
flake8-import-order==0.12
futurist==1.2.0
greenlet==0.4.10
hacking==0.12.0
hacking==1.1.0
idna==2.6
imagesize==0.7.1
iso8601==0.1.11
@ -82,9 +82,9 @@ pika-pool==0.1.3
Pint==0.5
positional==1.2.1
prettytable==0.7.2
pycodestyle==2.3.1
pycodestyle==2.0.0
pycparser==2.18
pyflakes==0.8.1
pyflakes==1.2.3
Pygments==2.2.0
pyinotify==0.9.6
pymongo==3.0.2


+ 1
- 1
test-requirements.txt View File

@ -10,7 +10,7 @@
hacking>=1.1.0,<2 # Apache-2.0
#
astroid==2.1.0;python_version>='3.0' # LGPLv2.1
bandit>=1.4.0 # Apache-2.0
bandit!=1.6.0,>=1.4.0,<1.6.3 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
doc8>=0.6.0 # Apache-2.0
flake8-import-order==0.12 # LGPLv3


Loading…
Cancel
Save