Browse Source

Merge "Updated from global requirements" into stable/kilo

Jenkins 3 years ago
parent
commit
0e4745faa8
3 changed files with 50 additions and 51 deletions
  1. 44
    44
      requirements.txt
  2. 0
    1
      setup.py
  3. 6
    6
      test-requirements.txt

+ 44
- 44
requirements.txt View File

@@ -7,57 +7,57 @@
7 7
 # be installed in a specific order.
8 8
 #
9 9
 # PBR should always appear first
10
-pbr>=0.6,!=0.7,<1.0
10
+pbr!=0.7,<1.0,>=0.6
11 11
 # Horizon Core Requirements
12 12
 Babel>=1.3
13
-Django>=1.4.2,<1.8
14
-Pint>=0.5  # BSD
15
-django_compressor>=1.4
16
-django_openstack_auth>=1.1.7,!=1.1.8,<1.3.0
17
-django-pyscss>=1.0.3,<2.0.0  # BSD License (2 clause)
18
-eventlet>=0.16.1,!=0.17.0
13
+Django<1.8,>=1.4.2
14
+Pint>=0.5 # BSD
15
+django-compressor>=1.4
16
+django-openstack-auth!=1.1.8,<1.3.0,>=1.1.7
17
+django-pyscss<2.0.0,>=1.0.3 # BSD License (2 clause)
18
+eventlet!=0.17.0,>=0.16.1
19 19
 httplib2>=0.7.5
20 20
 iso8601>=0.1.9
21 21
 kombu>=2.5.0
22 22
 netaddr>=0.7.12
23
-oslo.concurrency>=1.8.0,<1.9.0         # Apache-2.0
24
-oslo.config>=1.9.3,<1.10.0  # Apache-2.0
25
-oslo.i18n>=1.5.0,<1.6.0  # Apache-2.0
26
-oslo.serialization>=1.4.0,<1.5.0               # Apache-2.0
27
-oslo.utils>=1.4.0,<1.5.0                       # Apache-2.0
28
-pyScss>=1.2.1,<1.3  # MIT License
29
-python-ceilometerclient>=1.0.13,<1.1.0
30
-python-cinderclient>=1.1.0,<1.2.0
31
-python-glanceclient>=0.15.0,<0.18.0
32
-python-heatclient>=0.3.0,<0.5.0
33
-python-keystoneclient>=1.1.0,<1.4.0
34
-python-neutronclient>=2.3.11,<2.5.0
35
-python-novaclient>=2.22.0,<2.24.0
36
-python-saharaclient>=0.8.0,<0.9.0
37
-python-swiftclient>=2.2.0,<2.5.0
38
-python-troveclient>=1.0.7,<1.1.0
23
+oslo.concurrency<1.9.0,>=1.8.0 # Apache-2.0
24
+oslo.config<1.10.0,>=1.9.3 # Apache-2.0
25
+oslo.i18n<1.6.0,>=1.5.0 # Apache-2.0
26
+oslo.serialization<1.5.0,>=1.4.0 # Apache-2.0
27
+oslo.utils<1.5.0,>=1.4.0 # Apache-2.0
28
+pyScss<1.3,>=1.2.1 # MIT License
29
+python-ceilometerclient<1.1.0,>=1.0.13
30
+python-cinderclient<1.2.0,>=1.1.0
31
+python-glanceclient<0.18.0,>=0.15.0
32
+python-heatclient<0.5.0,>=0.3.0
33
+python-keystoneclient<1.4.0,>=1.2.0
34
+python-neutronclient<2.5.0,>=2.3.11
35
+python-novaclient<2.24.0,>=2.22.0
36
+python-saharaclient<0.9.0,>=0.8.0
37
+python-swiftclient<2.5.0,>=2.2.0
38
+python-troveclient<1.1.0,>=1.0.7
39 39
 pytz>=2013.6
40 40
 PyYAML>=3.1.0
41 41
 six>=1.9.0
42
-XStatic>=1.0.0  # MIT License
43
-XStatic-Angular>=1.3.7  # MIT License
44
-XStatic-Angular-Bootstrap>=0.11.0.2  # MIT License
45
-XStatic-Angular-lrdragndrop>=1.0.2.2  # MIT License
46
-XStatic-Bootstrap-Datepicker>=1.3.1.0  # Apache 2.0 License
47
-XStatic-Bootstrap-SCSS>=3  # Apache 2.0 License
48
-XStatic-D3>=3.1.6.2  # BSD License (3 clause)
49
-XStatic-Hogan>=2.0.0.2  # Apache 2.0 License
50
-XStatic-Font-Awesome>=4.2.0  # SIL OFL 1.1 License, MIT License
51
-XStatic-Jasmine>=2.1.2.0  # MIT License
52
-XStatic-jQuery>=1.7.2  # MIT License
53
-XStatic-JQuery-Migrate>=1.2.1.1  # MIT License
54
-XStatic-JQuery.quicksearch>=2.0.3.1  # MIT License
55
-XStatic-JQuery.TableSorter>=2.0.5b.0  # MIT License
56
-XStatic-jquery-ui>=1.10.1  # MIT License
57
-XStatic-JSEncrypt>=2.0.0.2  # MIT License
58
-XStatic-Magic-Search>=0.2.0.1  # Apache 2.0 License
59
-XStatic-QUnit>=1.14.0.2  # MIT License
60
-XStatic-Rickshaw>=1.5.0  # BSD License (prior)
61
-XStatic-smart-table>=1.4.5.3  # MIT License
62
-XStatic-Spin>=1.2.5.2  # MIT License
42
+XStatic>=1.0.0 # MIT License
43
+XStatic-Angular>=1.3.7 # MIT License
44
+XStatic-Angular-Bootstrap>=0.11.0.2 # MIT License
45
+XStatic-Angular-lrdragndrop>=1.0.2.2 # MIT License
46
+XStatic-Bootstrap-Datepicker>=1.3.1.0 # Apache 2.0 License
47
+XStatic-Bootstrap-SCSS>=3 # Apache 2.0 License
48
+XStatic-D3>=3.1.6.2 # BSD License (3 clause)
49
+XStatic-Hogan>=2.0.0.2 # Apache 2.0 License
50
+XStatic-Font-Awesome>=4.2.0 # SIL OFL 1.1 License, MIT License
51
+XStatic-Jasmine>=2.1.2.0 # MIT License
52
+XStatic-jQuery>=1.7.2 # MIT License
53
+XStatic-JQuery-Migrate>=1.2.1.1 # MIT License
54
+XStatic-JQuery.quicksearch>=2.0.3.1 # MIT License
55
+XStatic-JQuery.TableSorter>=2.0.5b.0 # MIT License
56
+XStatic-jquery-ui>=1.10.1 # MIT License
57
+XStatic-JSEncrypt>=2.0.0.2 # MIT License
58
+XStatic-Magic-Search>=0.2.0.1 # Apache 2.0 License
59
+XStatic-QUnit>=1.14.0.2 # MIT License
60
+XStatic-Rickshaw>=1.5.0 # BSD License (prior)
61
+XStatic-smart-table>=1.4.5.3 # MIT License
62
+XStatic-Spin>=1.2.5.2 # MIT License
63 63
 XStatic-term.js>=0.0.4 # MIT License

+ 0
- 1
setup.py View File

@@ -1,4 +1,3 @@
1
-#!/usr/bin/env python
2 1
 # Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
3 2
 #
4 3
 # Licensed under the Apache License, Version 2.0 (the "License");

+ 6
- 6
test-requirements.txt View File

@@ -7,21 +7,21 @@
7 7
 # be installed in a specific order.
8 8
 #
9 9
 # Hacking should appear first in case something else depends on pep8
10
-hacking>=0.10.0,<0.11
10
+hacking<0.11,>=0.10.0
11 11
 #
12 12
 coverage>=3.6
13 13
 django-nose
14
-mock>=1.0
14
+mock<1.1.0,>=1.0
15 15
 mox>=0.5.3
16 16
 nodeenv>=0.9.4 # BSD License
17 17
 nose
18 18
 nose-exclude
19 19
 nosehtmloutput>=0.0.3
20 20
 nosexcover
21
-openstack.nose_plugin>=0.7
22
-oslosphinx>=2.5.0,<2.6.0  # Apache-2.0
21
+openstack.nose-plugin>=0.7
22
+oslosphinx<2.6.0,>=2.5.0 # Apache-2.0
23 23
 selenium
24
-sphinx>=1.1.2,!=1.2.0,!=1.3b1,<1.3
25
-testtools>=0.9.36,!=1.2.0
24
+sphinx!=1.2.0,!=1.3b1,<1.3,>=1.1.2
25
+testtools!=1.2.0,>=0.9.36
26 26
 # This also needs xvfb library installed on your OS
27 27
 xvfbwrapper>=0.1.3 #license: MIT

Loading…
Cancel
Save