Browse Source

Bump pylint version to support python3.8

pylint 2.2.2 which we currently use does not support python 3.8 [1].

Let's use a newer version of pylint.

pylint now declares strict versions for astroid and isort,
so we do not need to manage them in our test-requirements.txt.

All new checks are disabled temporarily. Let's visit them later and
judge whether we disable them permanently one by one.

[1] https://github.com/PyCQA/pylint/issues/2737

Change-Id: I106b250e632305365aaab4d881c9ba5ea93505b3
changes/62/750862/2
Akihiro Motoki 1 year ago
parent
commit
235cbb839e
  1. 8
      .pylintrc
  2. 4
      test-requirements.txt

8
.pylintrc

@ -12,6 +12,7 @@ disable=
# "E" Error for important programming issues (likely bugs)
method-hidden,
no-member,
no-value-for-parameter, # TODO
not-callable,
# "W" Warnings for stylistic problems or minor programming issues
arguments-differ,
@ -23,6 +24,7 @@ disable=
keyword-arg-before-vararg, # TODO
pointless-string-statement,
protected-access,
raise-missing-from, # TODO
redefined-builtin,
redefined-outer-name,
signature-differs,
@ -31,6 +33,7 @@ disable=
unused-argument,
unused-wildcard-import,
useless-else-on-loop,
using-constant-test, # TODO
wildcard-import,
# "C" Coding convention violations
abstract-method,
@ -39,6 +42,7 @@ disable=
bad-continuation,
deprecated-lambda,
global-statement,
import-outside-toplevel, # TODO
invalid-name,
missing-docstring,
superfluous-parens,
@ -49,8 +53,11 @@ disable=
duplicate-code,
inconsistent-return-statements, # TODO
interface-not-implemented,
no-else-continue, # TODO
no-else-raise, # TODO
no-else-return,
no-self-use,
super-with-arguments, # TODO
too-many-ancestors,
too-many-arguments,
too-many-branches,
@ -59,6 +66,7 @@ disable=
too-many-locals,
too-many-return-statements,
too-many-statements,
unnecessary-comprehension, # TODO
useless-object-inheritance
[Basic]

4
test-requirements.txt

@ -9,17 +9,15 @@
# Hacking should appear first in case something else depends on pep8
hacking>=3.0.1,<3.1.0 # Apache-2.0
#
astroid==2.1.0 # LGPLv2.1
bandit!=1.6.0,>=1.4.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
flake8-import-order==0.12 # LGPLv3
isort<5 # MIT
nodeenv>=0.9.4 # BSD
pytest>=5.3.5 # MIT
pytest-django>=3.8.0 # BSD (3 clause)
pytest-html>=2.0.1 #MPL-2.0
python-memcached>=1.59 # PSF
pylint==2.2.2 # GPLv2
pylint==2.6.0 # GPLv2
selenium>=2.50.1 # Apache-2.0
testscenarios>=0.4 # Apache-2.0/BSD
testtools>=2.2.0 # MIT

Loading…
Cancel
Save