Browse Source

Merge "Bump hacking to 3.0.0"

tags/18.3.0
Zuul 2 months ago
committed by Gerrit Code Review
parent
commit
754804667a
2 changed files with 4 additions and 7 deletions
  1. +3
    -6
      lower-constraints.txt
  2. +1
    -1
      test-requirements.txt

+ 3
- 6
lower-constraints.txt View File

@@ -29,11 +29,8 @@ eventlet==0.18.2
extras==1.0.0
fasteners==0.7.0
fixtures==3.0.0
flake8==2.5.5
flake8-import-order==0.12
futurist==1.2.0
greenlet==0.4.10
hacking==0.12.0
idna==2.6
imagesize==0.7.1
iso8601==0.1.11
@@ -46,7 +43,7 @@ keystoneauth1==3.4.0
kombu==4.0.0
linecache2==1.0.0
MarkupSafe==1.0
mccabe==0.2.1
mccabe==0.6.0
monotonic==0.6
msgpack-python==0.4.0
munch==2.1.0
@@ -79,9 +76,9 @@ pika==0.10.0
pika-pool==0.1.3
positional==1.2.1
prettytable==0.7.2
pycodestyle==2.3.1
pycodestyle==2.5.0
pycparser==2.18
pyflakes==0.8.1
pyflakes==2.1.0
Pygments==2.2.0
pyinotify==0.9.6
pymongo==3.0.2


+ 1
- 1
test-requirements.txt View File

@@ -7,7 +7,7 @@
# be installed in a specific order.
#
# Hacking should appear first in case something else depends on pep8
hacking>=2.0.0 # Apache-2.0
hacking>=3.0.0,<3.1.0 # Apache-2.0
#
astroid==2.1.0 # LGPLv2.1
bandit!=1.6.0,>=1.4.0 # Apache-2.0


Loading…
Cancel
Save