Browse Source

Update lower constraints and change browser to Firefox to unblock gate

Pip 20.x requires ensure_str method from six which was introduced
in v.1.12.0 and wrapt v.1.11 is required by astroid v.2.4.0 with
the pylint dependency. So this patch update six and wrapt version
in lower-constraints.txt to fix the gate.

It also updates the browser to Firefox in karma.conf.js and adds
'karma-firefox-launchers' in package.json because nodejs-job
fail with chromium-browser due to not able to access some URL.
It also removes 'karma-chrome-launcher' enteries from all files
as it is no longer used.  So let's switch to Firefox browser to
unblock the gate then we can investigate later how to fix it with
chromium-browser.

Depends-On: https://review.opendev.org/c/zuul/zuul-jobs/+/766744

Co-Authored-By: Vishal Manchanda <manchandavishal143@gmail.com>
Change-Id: I13e68d89f55407b1b3c64219969912700feef500
(cherry picked from commit 6f0200032d)
changes/57/767357/1
Ivan Kolodyazhny 10 months ago
committed by manchandavishal
parent
commit
d8084fddc1
  1. 4
      horizon/karma.conf.js
  2. 4
      lower-constraints.txt
  3. 4
      openstack_dashboard/karma.conf.js
  4. 2
      package.json

4
horizon/karma.conf.js

@ -120,14 +120,14 @@ module.exports = function (config) {
frameworks: ['jasmine'],
browsers: ['Chrome'],
browsers: ['Firefox'],
browserNoActivityTimeout: 60000,
reporters: ['progress', 'coverage', 'threshold'],
plugins: [
'karma-chrome-launcher',
'karma-firefox-launcher',
'karma-jasmine',
'karma-ng-html2js-preprocessor',
'karma-coverage',

4
lower-constraints.txt

@ -111,7 +111,7 @@ Routes==2.3.1
selenium==2.50.1
semantic-version==2.3.1
simplejson==3.5.1
six==1.10.0
six==1.12.0
snowballstemmer==1.2.1
statsd==3.2.1
stevedore==1.20.0
@ -124,7 +124,7 @@ unittest2==1.1.0
vine==1.1.4
warlock==1.2.0
WebOb==1.7.1
wrapt==1.7.0
wrapt==1.11
XStatic==1.0.0
XStatic-Angular==1.5.8.0
XStatic-Angular-Bootstrap==2.2.0.0

4
openstack_dashboard/karma.conf.js

@ -160,14 +160,14 @@ module.exports = function (config) {
frameworks: ['jasmine'],
browsers: ['Chrome'],
browsers: ['Firefox'],
browserNoActivityTimeout: 60000,
reporters: ['progress', 'coverage', 'threshold'],
plugins: [
'karma-chrome-launcher',
'karma-firefox-launcher',
'karma-jasmine',
'karma-ng-html2js-preprocessor',
'karma-coverage',

2
package.json

@ -11,7 +11,7 @@
"eslint-plugin-angular": "1.0.1",
"jasmine-core": "2.4.1",
"karma": "1.1.2",
"karma-chrome-launcher": "1.0.1",
"karma-firefox-launcher": "2.1.0",
"karma-cli": "1.0.1",
"karma-coverage": "1.1.1",
"karma-jasmine": "1.0.2",

Loading…
Cancel
Save