OpenStack Dashboard (Horizon)
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.

test-requirements.txt 1.0KB

1234567891011121314151617181920212223242526
  1. # The order of packages is significant, because pip processes them in the order
  2. # of appearance. Changing the order has an impact on the overall integration
  3. # process, which may cause wedges in the gate later.
  4. # Order matters to the pip dependency resolver, so sorting this file
  5. # changes how packages are installed. New dependencies should be
  6. # added in alphabetical order, however, some dependencies may need to
  7. # be installed in a specific order.
  8. #
  9. # Hacking should appear first in case something else depends on pep8
  10. hacking>=1.1.0 # Apache-2.0
  11. #
  12. astroid==2.1.0;python_version>='3.0' # LGPLv2.1
  13. bandit>=1.4.0 # Apache-2.0
  14. coverage!=4.4,>=4.0 # Apache-2.0
  15. doc8>=0.6.0 # Apache-2.0
  16. flake8-import-order==0.12 # LGPLv3
  17. mock>=2.0.0 # BSD
  18. mox3>=0.20.0 # Apache-2.0
  19. nodeenv>=0.9.4 # BSD
  20. python-memcached>=1.59 # PSF
  21. pylint==2.2.2;python_version>='3.0' # GPLv2
  22. selenium>=2.50.1 # Apache-2.0
  23. testscenarios>=0.4 # Apache-2.0/BSD
  24. testtools>=2.2.0 # MIT
  25. # This also needs xvfb library installed on your OS
  26. xvfbwrapper>=0.1.3 #license: MIT