Add requirements.txt

It is nice to list packages required to run tools in the i18n repo
in requirements.txt.

Change-Id: Idcf10b551a1e08a98df13594124bc1b63e3987db
changes/93/442393/2
Akihiro Motoki 6 years ago
parent 8a5bbaee0e
commit 3e8b02e423

@ -0,0 +1,5 @@
beautifulsoup4 # MIT
oslo.log>=3.11.0 # Apache-2.0
requests>=2.10.0,!=2.12.2,!=2.13.0 # Apache-2.0
six>=1.9.0 # MIT
PyYAML>=3.10.0 # MIT

@ -7,4 +7,3 @@ hacking<0.11,>=0.10.2 # Apache-2.0
Babel>=2.3.4 # BSD
sphinx>=1.5.1 # BSD
oslosphinx>=4.7.0 # Apache-2.0
PyYAML>=3.10.0 # MIT

@ -7,7 +7,8 @@ skipsdist = True
install_command = pip install -c{env:UPPER_CONSTRAINTS_FILE:https://git.openstack.org/cgit/openstack/requirements/plain/upper-constraints.txt} {opts} {packages}
usedevelop = True
setenv = VIRTUAL_ENV={envdir}
deps = -r{toxinidir}/test-requirements.txt
deps = -r{toxinidir}/requirements.txt
-r{toxinidir}/test-requirements.txt
[testenv:venv]
commands = {posargs}

Loading…
Cancel
Save