Browse Source

Switch to newer openstackdocstheme and reno versions

Switch to openstackdocstheme 2.2.0 and reno 3.1.0 versions. Using
these versions will allow especially:
* Linking from HTML to PDF document
* Allow parallel building of documents
* Fix some rendering problems

Update Sphinx version as well.

Set openstackdocs_pdf_link to link to PDF file. Note that
the link to the published document only works on docs.openstack.org
where the PDF file is placed in the top-level html directory. The
site-preview places the PDF in a pdf directory.

Set openstackdocs_auto_name to use 'project' as name.

openstackdocstheme renames some variables, so follow the renames
before the next release removes them. A couple of variables are also
not needed anymore, remove them.

Change pygments_style to 'native' since old theme version always used
'native' and the theme now respects the setting and using 'sphinx' can
lead to some strange rendering.

See also
http://lists.openstack.org/pipermail/openstack-discuss/2020-May/014971.html

Change-Id: I6430e16e22a2afc0fda3a5a43eccfd3309f20931
changes/16/729316/3
Andreas Jaeger 2 years ago
parent
commit
533fd1ad52
  1. 11
      doc/source/conf.py
  2. 4
      test-requirements.txt

11
doc/source/conf.py

@ -36,9 +36,12 @@
extensions = ['openstackdocstheme']
# openstackdocstheme options
repository_name = 'openstack/i18n'
bug_project = 'openstack-i18n'
bug_tag = 'doc'
openstackdocs_repo_name = 'openstack/i18n'
openstackdocs_pdf_link = True
openstackdocs_bug_project = 'openstack-i18n'
openstackdocs_bug_tag = 'doc'
openstackdocs_auto_name = False
openstackdocs_auto_version = False
# Add any paths that contain templates here, relative to this directory.
# templates_path = ['_templates']
@ -98,7 +101,7 @@ exclude_patterns = []
# show_authors = False
# The name of the Pygments (syntax highlighting) style to use.
pygments_style = 'sphinx'
pygments_style = 'native'
# A list of ignored prefixes for module index sorting.
# modindex_common_prefix = []

4
test-requirements.txt

@ -5,6 +5,6 @@
hacking<2.1,>=2.0 # Apache-2.0
Babel!=2.4.0,>=2.5.3 # BSD
sphinx!=1.6.6,!=1.6.7,>=1.6.5 # BSD
openstackdocstheme>=1.28 # Apache-2.0
sphinx>=2.0.0,!=2.1.0 # BSD
openstackdocstheme>=2.2.1 # Apache-2.0
doc8>=0.8.0 # Apache-2.0

Loading…
Cancel
Save