Browse Source

tox -edocs doesn't work with Python3

Implementing the same pinning of python version as in the ironic specs
patch #440604:

The tox -edocs command does not work with Python3 because the command
depends on a library called "feedformatter" which only supports Python
2 for now.

Change-Id: I703b4a3a4df8c3ceb23adb09632ae5171e6f997e
Closes-Bug: 1669466
dparalen 2 years ago
parent
commit
2c937330a8
1 changed files with 2 additions and 0 deletions
  1. 2
    0
      tox.ini

+ 2
- 0
tox.ini View File

@@ -16,6 +16,8 @@ commands =
16 16
     doc8 README.rst doc/source specs
17 17
 
18 18
 [testenv:docs]
19
+# TODO(milan): remove the version pin once feedformatter supports python3
20
+basepython = python2.7
19 21
 commands = python setup.py build_sphinx
20 22
 
21 23
 [testenv:spelling]

Loading…
Cancel
Save