Browse Source

Update version of flake8-import-order package

Use latest version of flake8-import-order package, like we do in
openstack/ironic

Fix the issues detected by new version.

Change-Id: I3b016e35f98c8f88500824e612838f9923b4c3b9
changes/63/528063/1
John L. Villalovos 4 years ago
parent
commit
2064742523
  1. 3
      ironic_inspector/dbsync.py
  2. 3
      ironic_inspector/migrations/versions/882b2d84cb1b_attribute_constraints_relaxing.py
  3. 3
      ironic_inspector/migrations/versions/d588418040d_add_rules.py
  4. 4
      ironic_inspector/test/functional.py
  5. 3
      ironic_inspector/test/inspector_tempest_plugin/tests/test_discovery.py
  6. 3
      ironic_inspector/test/unit/test_keystone.py
  7. 1
      ironic_inspector/test/unit/test_plugins_capabilities.py
  8. 1
      ironic_inspector/test/unit/test_plugins_local_link_connection.py
  9. 3
      ironic_inspector/test/unit/test_plugins_standard.py
  10. 9
      ironic_inspector/test/unit/test_pxe_filter.py
  11. 2
      test-requirements.txt

3
ironic_inspector/dbsync.py

@ -19,10 +19,9 @@ import sys
from alembic import command as alembic_command
from alembic import config as alembic_config
from alembic import util as alembic_util
import six
from oslo_config import cfg
from oslo_log import log
import six
from ironic_inspector import conf # noqa

3
ironic_inspector/migrations/versions/882b2d84cb1b_attribute_constraints_relaxing.py

@ -25,11 +25,10 @@ branch_labels = None
depends_on = None
from alembic import op
from oslo_utils import uuidutils
import sqlalchemy as sa
from sqlalchemy.engine.reflection import Inspector as insp
from oslo_utils import uuidutils
ATTRIBUTES = 'attributes'
NODES = 'nodes'
NAME = 'name'

3
ironic_inspector/migrations/versions/d588418040d_add_rules.py

@ -25,9 +25,8 @@ branch_labels = None
depends_on = None
from alembic import op
import sqlalchemy as sa
from oslo_db.sqlalchemy import types
import sqlalchemy as sa
def upgrade():

4
ironic_inspector/test/functional.py

@ -11,10 +11,10 @@
# See the License for the specific language governing permissions and
# limitations under the License.
import eventlet # noqa
import eventlet
eventlet.monkey_patch()
import contextlib
import contextlib # noqa
import copy
import datetime
import json

3
ironic_inspector/test/inspector_tempest_plugin/tests/test_discovery.py

@ -10,9 +10,8 @@
# License for the specific language governing permissions and limitations
# under the License.
import six
from ironic_tempest_plugin.tests.scenario import baremetal_manager
import six
from tempest import config
from tempest.lib import decorators
from tempest import test # noqa

3
ironic_inspector/test/unit/test_keystone.py

@ -11,9 +11,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
import mock
from keystoneauth1 import loading as kaloading
import mock
from oslo_config import cfg
from ironic_inspector.common import keystone

1
ironic_inspector/test/unit/test_plugins_capabilities.py

@ -12,7 +12,6 @@
# limitations under the License.
import mock
from oslo_config import cfg
from ironic_inspector import node_cache

1
ironic_inspector/test/unit/test_plugins_local_link_connection.py

@ -12,7 +12,6 @@
# limitations under the License.
import mock
from oslo_config import cfg
from ironic_inspector import node_cache

3
ironic_inspector/test/unit/test_plugins_standard.py

@ -12,10 +12,9 @@
# limitations under the License.
import mock
import six
from oslo_config import cfg
from oslo_utils import units
import six
from ironic_inspector import node_cache
from ironic_inspector.plugins import base

9
ironic_inspector/test/unit/test_pxe_filter.py

@ -11,15 +11,14 @@
# See the License for the specific language governing permissions and
# limitations under the License.
import fixtures
import mock
import six
import stevedore
from automaton import exceptions as automaton_errors
from eventlet import semaphore
import fixtures
from futurist import periodics
import mock
from oslo_config import cfg
import six
import stevedore
from ironic_inspector.common import ironic as ir_utils
from ironic_inspector.pxe_filter import base as pxe_filter

2
test-requirements.txt

@ -3,7 +3,7 @@
# process, which may cause wedges in the gate later.
coverage!=4.4,>=4.0 # Apache-2.0
doc8>=0.6.0 # Apache-2.0
flake8-import-order==0.11 # LGPLv3
flake8-import-order>=0.13 # LGPLv3
hacking>=1.0.0 # Apache-2.0
mock>=2.0.0 # BSD
sphinx>=1.6.2 # BSD

Loading…
Cancel
Save