Browse Source

Cap jsonschema 3.2.0 as the minimal version

Previous versions of jsonschema (<3.2.0) doesn't support python 3.8 [1].
Python 3.8 is part of the victoria supported runtimes [2] so we now force
to use jsonschema version 3.2.0 to avoid issues, remove ambiguity and ensure
that everything works with python 3 in general.

[1] https://github.com/Julian/jsonschema/pull/627
[2] https://governance.openstack.org/tc/reference/runtimes/victoria.html#python-runtimes-for-victoria

Change-Id: I944e60f8c1962bfa3b6478b14e682eeca7948098
changes/50/730950/1
Hervé Beraud 2 years ago
parent
commit
5960cde402
  1. 2
      lower-constraints.txt
  2. 2
      requirements.txt

2
lower-constraints.txt

@ -13,7 +13,7 @@ futurist==1.2.0
hacking==3.0.1
ironic-lib==2.17.0
jsonpath-rw==1.2.0
jsonschema==2.6.0
jsonschema==3.2.0
keystoneauth1==3.18.0
keystonemiddleware==4.18.0
mock==3.0.0

2
requirements.txt

@ -9,7 +9,7 @@ Flask>=1.0 # BSD
futurist>=1.2.0 # Apache-2.0
ironic-lib>=2.17.0 # Apache-2.0
jsonpath-rw<2.0,>=1.2.0 # Apache-2.0
jsonschema>=2.6.0 # MIT
jsonschema>=3.2.0 # MIT
keystoneauth1>=3.18.0 # Apache-2.0
keystonemiddleware>=4.18.0 # Apache-2.0
netaddr>=0.7.18 # BSD

Loading…
Cancel
Save