Browse Source

Stop supporting Flask < 1.0

Latest version of Werkzeug (1.0.0 at the moment) broke
compatibility with older Flask, actually causing issues when
running lower-constraints tests, since Flask will install
highest version of Werkzueg after 0.7.
With this patch we require Flask to be at least version 1.0
to re-establish compatibility.

See failed test https://review.opendev.org/706701 or run
lower-constraints test locally for confirmation.

Change-Id: Id05b4a205379fdf1b26cb239757bd370f3fe88e3
changes/02/706702/3
Riccardo Pittau 1 week ago
parent
commit
ba8ecd3cf5
2 changed files with 3 additions and 3 deletions
  1. +2
    -2
      lower-constraints.txt
  2. +1
    -1
      requirements.txt

+ 2
- 2
lower-constraints.txt View File

@@ -8,7 +8,7 @@ doc8==0.6.0
eventlet==0.18.2
fixtures==3.0.0
flake8-import-order==0.13
Flask==0.10
Flask==1.0
futurist==1.2.0
hacking==1.0.0
ironic-lib==2.17.0
@@ -48,4 +48,4 @@ stestr==1.0.0
stevedore==1.20.0
testresources==2.0.0
testscenarios==0.4
tooz==1.64.0
tooz==1.64.0

+ 1
- 1
requirements.txt View File

@@ -6,7 +6,7 @@ alembic>=0.8.10 # MIT
Babel!=2.4.0,>=2.3.4 # BSD
construct<2.9,>=2.8.10 # MIT
eventlet!=0.18.3,!=0.20.1,>=0.18.2 # MIT
Flask!=0.11,>=0.10 # BSD
Flask>=1.0 # BSD
futurist>=1.2.0 # Apache-2.0
ironic-lib>=2.17.0 # Apache-2.0
jsonpath-rw<2.0,>=1.2.0 # Apache-2.0

Loading…
Cancel
Save