Browse Source

Bump hacking min version to 3.0.1

flake8 new release 3.8.0 added new checks and gate pep8
job start failing. hacking 3.0.1 fix the pinning of flake8 to
avoid bringing in a new version with new checks.

Though it is fixed in latest hacking but 2.0 and 3.0 has cap for
flake8 as <4.0.0 which mean flake8 new version 3.9.0 can also
break the pep8 job if new check are added.

To avoid similar gate break in future, we need to bump the hacking min
version.

- http://lists.openstack.org/pipermail/openstack-discuss/2020-May/014828.html

Change-Id: I2a903c90d72cd596ef976d9aab478f96a2750680
changes/23/728723/3
zhangbailin 2 years ago
parent
commit
c2224fde50
  1. 2
      lower-constraints.txt
  2. 2
      test-requirements.txt

2
lower-constraints.txt

@ -10,7 +10,7 @@ fixtures==3.0.0
flake8-import-order==0.17.1
Flask==1.0
futurist==1.2.0
hacking==3.0.0
hacking==3.0.1
ironic-lib==2.17.0
jsonpath-rw==1.2.0
jsonschema==2.6.0

2
test-requirements.txt

@ -6,7 +6,7 @@ bandit!=1.6.0,>=1.1.0,<2.0.0 # Apache-2.0
coverage!=4.4,>=4.0 # Apache-2.0
doc8>=0.6.0 # Apache-2.0
flake8-import-order>=0.17.1 # LGPLv3
hacking>=3.0.0,<3.1.0 # Apache-2.0
hacking>=3.0.1,<3.1.0 # Apache-2.0
sphinx>=2.0.0,!=2.1.0 # BSD
sphinxcontrib-svg2pdfconverter>=0.1.0 # BSD
sphinxcontrib-apidoc>=0.2.0 # BSD

Loading…
Cancel
Save