Browse Source

Install libssl-dev / openssl-devel when building IPA

It is required to compile the cryptography module.

Change-Id: I3a2d889094db2b4c43be32968bd3602c47f7f032
Story: #2007214
Task: #40823
tags/2.2.0
Dmitry Tantsur 3 weeks ago
parent
commit
8602442973
2 changed files with 4 additions and 0 deletions
  1. +3
    -0
      dib/ironic-python-agent-ramdisk/package-installs.yaml
  2. +1
    -0
      dib/ironic-python-agent-ramdisk/pkg-map

+ 3
- 0
dib/ironic-python-agent-ramdisk/package-installs.yaml View File

@@ -23,6 +23,9 @@ efivar:
chrony:
e2fsprogs:
libffi-dev:
build-only: true
libssl-dev:
build-only: true

# The base minimum element uninstalls firmware, but it's needed for bare metal.
linux-firmware:


+ 1
- 0
dib/ironic-python-agent-ramdisk/pkg-map View File

@@ -32,6 +32,7 @@
"curl": "curl",
"ironic-python-agent": "openstack-ironic-python-agent",
"libffi-dev": "libffi-devel",
"libssl-dev": "openssl-devel",
"qemu-utils": "qemu-img",
"python-dev": "python-devel"
},


Loading…
Cancel
Save