Browse Source

Fix tox.ini to correctly test lower-constraints

Due to the way we currently define install_command, all test targets
are using upper-constraints, including the lower-constraints one.
This patch fixes it and adds standard things like passing proxy settings.

Change-Id: I61c3b45ae591ea44688f29598cb8b802bb094423
(cherry picked from commit 91ed55678e)
tags/3.3.3^0
Dmitry Tantsur 4 months ago
parent
commit
5a7cd98998
1 changed files with 6 additions and 2 deletions
  1. +6
    -2
      tox.ini

+ 6
- 2
tox.ini View File

@@ -5,15 +5,19 @@ envlist = py3,py27,functional,pep8

[testenv]
usedevelop = True
install_command = pip install -U -c{env:UPPER_CONSTRAINTS_FILE:https://opendev.org/openstack/requirements/raw/branch/stable/rocky/upper-constraints.txt} {opts} {packages}
install_command = pip install -U {opts} {packages}
setenv =
VIRTUAL_ENV={envdir}
PYTHONDONTWRITEBYTECODE = 1
OS_TEST_PATH=./ironic_python_agent/tests/unit
LANGUAGE=en_US
LC_ALL=en_US.utf-8
deps = -r{toxinidir}/test-requirements.txt
deps =
-c{env:UPPER_CONSTRAINTS_FILE:https://releases.openstack.org/constraints/upper/rocky}
-r{toxinidir}/requirements.txt
-r{toxinidir}/test-requirements.txt
commands = stestr run {posargs}
passenv = http_proxy HTTP_PROXY https_proxy HTTPS_PROXY no_proxy NO_PROXY

[testenv:functional]
basepython = python3

Loading…
Cancel
Save