Browse Source

Upgrade version of doc8

The doc8 module explicitl supports Python 3.6 starting from version
0.8.1

Also remove it from test-requirements as we already have it in tox.ini

Change-Id: Idc66758dc350d9a7a09b4295b08f4423cec288dc
changes/56/766956/1
Riccardo Pittau 10 months ago
parent
commit
67ee66785c
  1. 3
      test-requirements.txt
  2. 2
      tox.ini

3
test-requirements.txt

@ -1,11 +1,10 @@
# The order of packages is significant, because pip processes them in the order
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
coverage!=4.4,>=4.0 # Apache-2.0
testtools>=2.2.0 # MIT
oslotest>=3.2.0 # Apache-2.0
stestr>=1.0.0 # Apache-2.0
bandit!=1.6.0,>=1.1.0,<2.0.0 # Apache-2.0
# Doc test requirements
doc8>=0.6.0 # Apache-2.0

2
tox.ini

@ -38,7 +38,7 @@ deps=
bashate>=0.5.1 # Apache-2.0
flake8-import-order>=0.17.1 # LGPLv3
pycodestyle>=2.0.0,<2.7.0 # MIT
doc8>=0.6.0 # Apache-2.0
doc8>=0.8.1 # Apache-2.0
whitelist_externals = bash
commands =
flake8 {posargs:ironic_python_agent examples}

Loading…
Cancel
Save