Drop python2 from bindep.txt

IPA dropped support for Python2 long ago,
and now Python2 is not even available in newer distros,
breaking installation if IPA binary dependencies.

Depends-On: https://review.opendev.org/c/openstack/ironic/+/848345
Change-Id: I75a618f94de58f6de2bd96b37de1894bb0e61998
changes/71/845371/3
Pavlo Shchelokovskyy 8 months ago committed by Jay Faulkner
parent 9dca97736f
commit d8a6bf5f61

@ -1,7 +1,5 @@
# these are needed to compile Python dependencies from sources
python-dev [platform:dpkg test]
python3-all-dev [platform:dpkg !platform:ubuntu-precise test]
python-devel [platform:rpm test]
python3-devel [platform:rpm test]
build-essential [platform:dpkg test]
libssl-dev [platform:dpkg test]
@ -25,7 +23,7 @@ libguestfs [platform:rpm imagebuild]
python-guestfs [platform:dpkg imagebuild]
# for TinyIPA build
wget [imagebuild]
python-pip [imagebuild]
python3-pip [imagebuild]
unzip [imagebuild]
sudo [imagebuild]
gawk [imagebuild]

Loading…
Cancel
Save